Cannot reach 22.4 for Wahoo SNAP spindown anymore


(Jeannie) #1

I’ve been using my new SNAP for a month or so and always perform the suggested spindown exercise with no issues. Suddenly last ride I was unable to get up to 22.4 mph. I barely made 18 mph and working extremely hard. I gave up and just rode. Seemed a bit off but not bad. I’m back again and exact same problem. I’ve now adjusted the tension several times, so I know it’s not calibrated correctly. Any suggestions? Very frustrated. Thanks.


(Steven Alcorn) #2

This happened to me once as well with the KICKR Snap. I simply closed Zwift and reopened it, and the problem was gone. Have you tried doing the spindown using the Wahoo app, and if so, does it work normally?


(Jeannie) #3

I just tried again and this time it worked. I unpaired everything and made sure Zwift was not running. I’ve always done the spindown in the wahoo app on my phone. If I try in Zwift it’s too hard. So maybe that’s the problem. I’ll post again if anything changes. Thanks for the response.


(Karl Mack) #4

I have the Kickr Snap, too, and this problem also occurs on mine.

I realized that, even though the calibration window is on screen, Zwift somehow does not realize it should calibrate. Instead, you get the resistance which you have riding at the place you are.Also, in the background I could see my avatar was riding (which should not be the case). Closing the menu, I could also see that I had pushed out some good watts on the power graph at the bottom.

In my case, it was good enough to close the window with the calibration stuff, go back to the pair-screen and click again on the settings menu at your trainer. Sometimes has to be done twice or so. The moment it works you will feel the lower resistance.

Hope that helps


(Michael Lee MTCCNJ) #5

Do you have an external power meter controlling your KICKR? I noticed that this can affect getting up to the deisred speed to complete the spindown. You can always toggle on/off in the Wahoo Fitness app settings.


(Jeannie) #6

I don’t have a power meter. I still haven’t totally figured this thing out. If I turn off my bluetooth on my computer (where I use Zwift) I can calibrate with the wahoo iphone app most of the time, but I still get the resistance every 3rd or 4th time. Same variables as far as I can tell, but it’s not regular enough to cause me worry. Not calibrating every so often doesn’t seem to change things. thanks for the tip!


(Philippe) #7

I have been using my kickrsnap for a couple of years and I thought I had found the solution:calibrating every time, backtire inflated at 100 psi and 2 exact turns when backtire touches the trainer. Not enough. So frustrating!!!
Finally deleted the Wahoo app and reinstalled it and it worked :flushed:
My next trainer may not be that one though…wasting too much time with this…