Zwift subscription from iPad using iTunes not updated

Anyone experiencing issue when subscribing zwift using iTunes? It seems like it is not being updated since the upgrade of the new app.

Older app had the “RESTORE” option which allows you to update your subscription instantly.

Unfortunatelly with this new app this restore button is no longe available. … pain in the neck. Paying subacription but limited to trial 25kms only.

Hi Badak,

If you contact the support team they should be able to help.

There’s normally a bit of a delay with iTunes payments.

Justify “a bit of delay”. Can you elaborate more, How many hours are you referring to?

If you upgrade your app, why did you remove a perfectly working button?

We as consumer will not be upset and disappointed if you were to keep the restore button or address this issue and fix it as a priority.

Seems like no matter whar consumer’s feebackprovided, zwift just completely ignored and disregard it. Falling to deaf ears, thanks!!!

I’m afraid I don’t work in support so I can’t answer any of your questions. I would recommend that you contact them.

All I am trying to do is help you, so your comments are unnecessary.

Have you tried force-closing the app and starting up again? That often works. Also, I’m reasonably sure that if you ride to the end of that 25k trial the Restore Purchase option will pop up. (At least it did in the past couple of releases.)

Kind of crazy they took it off of the initial screen, but you should still be able to ride.

Tried mutiple times by closing the app but unsuccessful. No other option available, restore purchase button was removed. Got a reply from Alicia from support, she had to manually activate it. Seems like there is no other solution. If you encounter this issue, you have to email zwift and wait until they activate your subscription. Due to time difference, you may lose a day. Thanks zwift, seems like you have gone backwards since you deployed the new app.

Did you read what I wrote?

“Also, I’m reasonably sure that if you ride to the end of that 25k trial the Restore Purchase option will pop up. (At least it did in the past couple of releases.)”

No, it didn’t appear, thus the reason support team had to manually activate my subscription

Well, now THAT is a bummer! It was bad enough when the ‘Restore Purchase’ button on the home screen went away, but if they have now also taken away that option at the end of the 25k trial that is a travesty. I truly wish they would fix this. I don’t have this issue often, but it is surely a PITA when I do.

This is really sad, but the only current solution is to not pay via Apple. You should not have to do this, and it’s a terrible user experience, but paying via the Zwift website is the only way.

I know that I would rather pay directly through Zwift. However, since there really isn’t anything I ‘need’, a Zwift subscription is an easy thing for family members to get for birthdays and holidays. And since Zwift discontinued their own gift cards, Apple gift cards are the next easy substitute.

1 Like

I have had the issue every winter season when I reactivated Zwift. The issue appears when using my account on a device where my Apple ID is not the default.
The solution is easy though: I start Zwift on the device from where I purchased Zwift (my iPhone) and there it has always worked to reactivate. Then it also works when starting Zwift on eg the iPad.