Zwift starts but get only black screen

I have been using Zwift without an issue for years. Now, when I start it, and the game starts, my screen goes black. If I hit the “windows” key twice, I get back to my desktop, and can see zwift running in taskbar. if I hover mouse over icon, I can see the zwift window - looks like it started just fine. but if I click on the window to try to enter the game, it goes back to black screen. Very strange. I have: uninstalled and reinstalled two versions of vid drivers (Nvidia 1060), uninstalled and reinstalled zwift twice, once in a different directory, rebooted computer several times. I keep getting the same behavior. I tried Rouvy last night - I need something - and I need my Zwift back!

Have you tried changing your screen resolution? What has changed recently since this started to happen?

1 Like

I have tried playing with screen resolution, though I had done nothing to change it leading up to this very strange problem. I’ve gone through an uninstalled any recently installed apps. I’m going to try to reboot in safe mode and see what happens.

Hi, I’m now having the same issue and have made no changes it just happened one day after both laptop and TV monitor working fine for years. Very frustrating, have you resolved the issue? More importantly has anyone from Zwift commented?

I have now developed this same problem. The program begins to launch and it goes to a black screen. I can hear the Zwift music but no video appears. I cannot reach Zwift support. Did anyone solve this problem?

I did, you just go to windows view (were you see an exact copy of your laptop screen on tv) but have forgotten how I did it exactly. You have to go into your settings or zwift files, sorry can’t be of more help.

I can’t even get into the game to change any settings! I’ve emailed support and haven’t heard back and tried calling without success. I am sad!

I think the files are on your pc or laptop not zwift. If I remember correctly there is a zwift file.

Stuart, thanks for the hint. I found the preferences file in the Zwift folder. I edited it from full screen to windowed and, voila, Zwift worked! It no longer runs just in the taskbar. Thanks!

Thanks so much for talking about this. I thought it was just me. It’s been a total punish. Great workaround hope there’s a fix in next update

I’ve had a similar issue on a new install (Win10 + GTX 1660 + 4k TV via HDMI). After enabling full-screen within zwift, the next start of zwift came with a blank screen.

While playing with various settings I’ve noticed, windows set a refresh-rate of 30Hz … but the settings of the nvidia driver didn’t allow such low rates in some places.

I’m not sure if this was coincidence / luck - but when I’ve set the refresh-rate to 60Hz, zwift started to work in full-screen mode, too.

1 Like