Zwift Runpod - Avatar stops running

I am using an iPad with IOS 16.2, Zwift version 1.33.2 with a Zwift run pod I just purchased in January 2023. When my treadmill is set higher than 6 mph the avatar stops running until I slow the treadmill down to less than 6. Very frustrating. My treadmill is NOT connected to Zwift. Any ideas?

Does it still do this during the calibration process?

If it’s a speed related issue it should fail to calibrate.

Thanks for your quick response. I’ll give calibration a try and get back to you.

Hey Stuart, I tried calibrating. Didn’t work. Starting speed was 6mph. That worked. Then it told me to go to 5.1. Got an error message at this speed for 3 tries. I’ll try again tomorrow morning after a good warm up.

Only thing I can suggest is reset it by taking the battery out, wait 10 seconds, and out it in again, then try the calibration mentioned above.

Actually, thinking about this, I think that is the calibration process it is going through! It tells you to drop to 5.1 mph during the calibration process so maybe it is forcing him to go through the calibration process before he can start using it??

Solved the problem by replacing the battery. So, I’m not sure if it was just a reset that was required or if the battery that was supplied with the RunPod was weak. Thanks very much for your quick responses to my question and your good suggestions.