Zwift pod works when running fast, but avatar constantly stopping when jogging/walking

(Catherine) #1

I am trying to figure out why my pod works well at high speed but doesn’t below about 6mph.

I received a new running pod yesterday and struggled to get it working - all calibrations failed and when I’d try and run, my avatar would constantly stop and start. I had the speed of my treadmill fairly slow (4-6mph) during all of this. I was convinced there was BLE signal interference, so tried to troubleshoot that way before finally just giving up. I started doing a run workout, and started running 8mph+. The pod worked perfectly fine. Decided to try and calibrate at a much higher speed than before (8mph, 7.1, 8.9) and it worked.

Had anyone had this issue and managed to correct it? TIA!

(Annie Kearns (HERD)) #2

Just got my Zwift Run pod and was so excited to get running. I was paired to my Wahoo Tickr before, but the avatar would only move when I was walking and would stop when I’d run. Now, with the zwift pod, I can only RUN and I can’t walk or jog. Sigh. SO Frustrating.

2 Likes
(Andrew Sheppard) #3

I use a Milestone Pod and have just had my first run in about a month and I experienced exactly the same issue. I have my treadmill set at 6.5 mph and my avatar would constantly stop and start which it never has before with exactly the same setup. I reset my Pod and refreshed all my links but it still doesn’t work. If anyone can help us it would be appreciated!

2 Likes
(Todd Ericson) #4

Same problem here. Just received the run pod and the avatar is constantly stopping. Not making for a very enjoyable run. Frustrated!

1 Like
(Tim) #5

Same problem here. My wife was excited to try the runpod but walking doesn’t work well at all…

(Jon) #6

What sort of cadence are you running at? My RunPod works as low as 4.2kph but only smoothly with a cadence of above around 105. If I slow my cadence down then the Avatar will stop.

(Andrew Sheppard) #7

Hi Jon, i run with a steady cadence of around 150. it always used to work perfectly and i was using it every week up until the start of November. Then i had a little injury which stopped me training for a month and now i have this stop and start problem. its like there is some interference as it will be working fine, then i will instantly stop, and then i will be back up to speed again. it doesn’t seem to affect other runners “in screen” as they keep smoothly running at their pace. That makes me think its my Milestone Pod causing the problem but my wife had a brand new one for Christmas and the same thing is happening to her on her account and new pod. Its frustrating!!

1 Like
(Jon) #8

Have you update the firmware recently? There was an update to the milestone app released towards the end of Dec that allowed it to recognise the Zwift RunPod and as soon as I connected mine it updated the firmware.

(Andrew Sheppard) #9

Yeah i did that but ironically when it got to 100% complete i had an error message so i wasn’t sure if it applied or not. I tried to update it again and it said it was up to date so i just assumed it worked. I read somewhere on another forum that Milestone have acknowledged there was a bug with this but they are patching an update for next week but it shouldn’t affect performance. it should also be noted that i only did this AFTER i started having the problem mentioned above, And like i said before, my wife has the same issue with her pod in zwift so i don’t think the issue is related. Thanks for your responses though, they are appreciated.

1 Like
(Catherine) #10

Yea, my cadence is high too - 160+. I’ve continued to use my Zwiftpod and the issue has been pretty consistent - only when I am running consistently fast does it continually work. I’m starting to wonder if it’s related to the force of impact…

(Jon) #11

I’ve just seen in another group that there is an update out for the iOS version of Zwift that includes fixes for this. I’m using a PC which could explain why I’m not seeing the issue.

(Andrew Sheppard) #12

Yeah i am using my iphone and I saw there was an update yesterday which i hoped would fix the problem but i tried it again this morning and its still the same :frowning:

(Andrew Sheppard) #13

Catherine - random (and somewhat obvious) thought - have you tried re-calibrating your runpod in Zwift recently? i just looked at the update details for the recent Zwift app updates on itunes and they have changed the calibrating system in December. i just realised i haven’t tried this so might give it a go later and see if it makes any difference? fingers crossed!!

1 Like
(Andrew Sheppard) #14

Update - i tried the calibration last night and i thought i had cracked it as i ran for 10 minutes with no stop/starting but just when i was about to end my test it started happening. Grrrrrr! The only thing that changed at the time was i increased my run speed, but i had been changing that throughout my test to see if it had an effect and up until that point it didn’t. Back to the drawing board.

(Catherine) #15

I’ve tried recalibrating, too, but no luck. I’m officially stumped and am going to msg Zwift directly… I’ll post again if I learn anything helpful.

(Andrew Sheppard) #16

OK thanks. i raised an official support ticket with Zwift a few days ago but not had a response yet. i’ll also share any findings when they get back to me.

(Ryan Kilgore [TFC C]) #17

Same problem here. Bought the Zwift RunPod for my kids to use on the treadmill as they loved watching me on my smart trainer. But there are repeated problems calibrating it, and the same problems you all have mentioned with the avatar intermittently not running, and seemingly more pronounced at lower speeds. My kids are 8 and 10, and my younger one has more problems than my older. Very frustrating, as they’re super excited to run and collect experience and gain new in-game clothes, but the intermittent problems really sap their motivation. They have been using an iPad to run Zwift, but this evening I tried setting them up on my MacBook. It seemed to work a lot better at first, but then later the same problems cropped up again. Would like to hear from the folks at Zwift to know whether this is a problem with the RunPod or with the Zwift app, and whether it can be fixed in a software or firmware update. Otherwise, this isn’t going to work for us.

1 Like
(Abi Hall) #18

I have the same problem. I contacted Zwift and they said they were aware of the problem and the developers are working on a firmware update to fix the problem. Pretty unimpressed that they’re selling something that they know doesn’t work!!

(Miriam Scott Goddard) #19

Same problem. As I only bought the foot pod so I could do hill training (changing speed and cadence constantly) this is really pointless. How can they sell this!?

(Andrew Sheppard) #20

Hi all,
I have been in contact with Milestone Pod (as that is the pod i am using) and they said that they know there is still a problem with this (since the last Zwift update) so they asked me to do some testing for them which involved using other apps like RunSocial. For doing this for them they are sending me a new runpod (handy to have a backup i guess?). Just as an FYI they also confirmed the new Zwift branded Milestone Pods are exactly the same as the old Pods, they have just changed the plastic casing.
In any event they contacted me yesterday and said that they (Zwift) will be releasing a new patch later this week to hopefully resolve this issue so fingers crossed everything will be back to working properly by this time next week :slight_smile:

1 Like