Zwift Run Pod (red blinking) issue

Hello Zwift,

I am having problems with the run pod. I’ve had the run pod for about a couple of months. I rely on this tool when it rains and the day I want to use it, a red light blinks. I have tried to reset everything, changed the battery, and reconnect it. It connects to Bluetooth but does NOT show data or make the avatar move. This is very frustrating. Is there a way to either fix this issue or get a replacement? There’s a lot of complaints about this and Zwift’s name is on the line to fix this. Thanks!

Hi @Andrew_Rioveros

When did you get the RunPod? Is it an older one before Zwift purchased Milestone (the company that develped it)?

It sounds like you’ve done most of the steps in this Support Hub article.

You didn’t mention if you did or not - have you tried updating the firmware?


Thank you for response. I got the run pod around March or April of 2020. It worked perfectly then. It stopped worked around December of 2020 and wanted to try it just recently and it still does not read my data or move the avatar but shows BT connectivity.

When I connect the run pod, it does not lead me to an update automatically. There is no option to update. Only to calibrate. But calibrating doesn’t work because it won’t sense speed but still connect to BT.

Hi @shooj,

Hope everything is well. Just wondering if you were able to get my previous message. Thanks!

Hi @Andrew_Rioveros

If you’ve taken all the steps in that Support Hub article - the next step would be for you to contact our agents for a possible warranty claim. You can initiate that on There will be a AI bot that will ask questions and funnel you to the right human team for help. You know that drill.

I have the same issue. Were you able to resolve it or did support give you any solutions?