ZwiftPod issues

Apologies if this has somehow been covered however even contacting Zwift support didn’t offer much help…

I got given a Zwift Run pod for Xmas 21… Used it fine for a fair bit of last year till I got injured and stopped running around August time. Since then it’s been sat there collecting dust.

I picked it up yesterday and changed the batteries and connected it to my phone (Samsung S22 Ultra if that makes a difference). All seemed to be going well, Zwift is picking up the sensor & cadence sensor however that’s as far as it’ll go as it’s showing 0 mph and not letting me calibrate it at all.

I’ve tried force stopping Zwift, resetting Bluetooth, another new battery etc etc. There’s no green firmware upgrade either as seen in the photo (if it attaches). The app / phone is picking up the sensor and it’s showing good connection so stuck at why it’s not moving.

Hi @Michal_Roman

Welcome to the forums!

First thing you’ll want to to is unpair it from your phone. It’s ok if the phone “sees” the runpod, but directly pairing it to the phone will keep Zwift from getting the data from it. Once you’ve done that, open up Zwift, pair it up there and you should be good to go. If that doesn’t work, reach out to us and we can continue to troubleshoot this with you.

Cheers John, I have already tried that, nothing seems to be getting it to actually pick up any data.