Red light/foot pod not working

I got my zwift foot pod yesterday. I have been using the cycling version for a couple weeks. I got the pod in the mail and had no issues setting it up. syncd right up. calibrated it and went on a nice little 5k run.

This morning I go to run and I notice the light on the pod is red instead of green. I dont think anything of it until I get logged in and notice that it sync’d but I am running and my avatar is not. Everything I tried, I could get it to pair, but he wouldn’t move.

  • Tried restarting phone and laptop.
  • tried to run zwift through my desktop and then on my phone. Same issue.
  • Put my phone in airplane mode and disabled mobile data.
  • Checked to make sure it didn’t pair through bluetooth on my phone.
  • Switched batteries(even though it was brand new)

The only thing i can think of is that the red light is some sort of error.

Not sure if this helps, but I was using a Android and I tried it on my wifes iphone. Same issue. Everything pairs up fine, but no movement. Jumped back over to my kinectic trainer for a cycle and it worked perfectly fine.

My wife had the same issue on the same brand new Zwift Run Pod (also same red light). My Garmin foot pod has had no issues, although it has the disadvantage that it is only ant+ and I have to connect to computer. Any solution to this issue would be welcome.

I’m having the same problem. Zwift support has not been helpful with it.

Hi Jeff,

I’m also taking a look at the support request you submitted to our team regarding this same issue. I dug up some information about the Zwift Runpod and the only pertinent information I found regarding the “red light” has do do with the battery life.

Tapping brings a battery level battery 100-60% full - green, 60-30% orange, <30% red

That doesn’t exclude the possibility that you have a defective unit, but I’ll go ahead and analyze your log files and get back to you via email with further troubleshooting tips. Thanks!

I’ve already had to replace the battery 2 times in about 2 weeks with only 4 or 5 runs.

2 Likes

update

I noticed that yesterday google had a update for the milestone pod app. After my phone updated I tried to sync my zwift pod and it was found right away were before it wasnt found at all. It sync’d right up and had a firmware update that took about 5 mintues to complete. once complete it sync’d the first run that i did on zwift about a week ago. It also had a green light on the pod and the app showed my battery at 50%. I turned on zwift and did a few laps in my living room and my avatar moved right away.

This morning it sync’d it and did a 3 mile run. I calibrated it first and then did a 3.5 mile workout. Worked perfectly. It also showed my battery at around 90%.

I would assume that whatever came through on the app and firmware fixed my issue. I have another run scheduled for Friday that I should confirm it is still working.

I am having the same issue and have submitted a ticket as well. I too have noticed that if I replace the battery I will get maybe two runs out of it and it is the same thing all over again. I say defective and should either refund or replace! I will update with what i find out.

Same issue after 1 run. Bought from Amazon & returning for full refund. Will wait until this product doesn’t have such a bad reputation before considering buying again.

So I’ve gotten slightly better battery usage by using iPad and turning bluetooth off right after the run. I’ve also installed the latest firmware update with the Milestone app. I’m going to give it another month or so and see if the same battery lasts before I request a refund and switch to another pod.