Run Pod issues


(Jon Burrage) #1

I have got hold of a footpod mainly for my wife to run on a treadmill (she isnt comfortable with running on her own in the dark after work when I am looking after our little boy) and after one run the pod is now flashing red which, as far as the internet tells me, means there is a battery issue. It was also a total pig to connect initially and had frequent drop outs (14 in 5k) which were not avg corrected and simply look liks gaps or stops in the run. Also the run was approx 2kmh slower than the calibrated treadmill was suggesting. All in all lots of issues and pretty frustrated at this point.

I really want this to work for her but am struggling to figure out the gremlins right now, any guidance would be appreciated. Thanks.


(Jon Burrage) #2

Further - bought new battery, fitted, it found the pod and worked for 4 minutes but again the speed was way out so tried to recalibrate as per the zwift instructions. Red light comes back on, no chance of calibration happening because zwift beta and the companion bridge cannot see the pod. What is going on, I want to return this unit for a refund please.