Zwift Rides Not Syncing with Garmin Connect [December 2021]

any other recommendation?.. would it be useful to uninstall the app?

@Jose_Antonio_De_Echa My connection has been working forever but thought I would uninstall and reinstall to see if I could help you …

On Android, I deleted the Companion App then reinstalled. The initial connection attempt momentarily bought up a Garmin authorisation screen but it immediately disappeared and no connection made. Now when I go to add Garmin, nothing happens.

From the web, The auth box asks for Garmin credentials, which is prepopulated, I then go through the Garmin username/pwd, accept agreements then get an error

This failure is repeatable if I keep doing the same thing.

Then rather than accepting the pre-populated Garmin credentials, I manually entered them and connection was successful. So hopefully that works for you.

1 Like

thank you, i¨ll try in this way

Very often my activity fails to sync to Garmin Connect but syncs fine with Strava.
If I try to manually import the FIT file to Garmin Connect it fails, but usually, when I run it through the corrupt time fixer tool on, the corrected file imports successfully.

1 Like

I did it several times and it didn’t work

I mean, Dean´s recomendations

Bugga … hopefully its gets sorted for you Jose.

thanks for this advice. had exactly the same issue like you (did not syn to GC but strava works fine). then used the corrupt time fixer and now it works. WTF

An alternate approach if you’re using Strava… download the GPX file from Strava and upload that to Garmin Connect. Works every time.

I suspect something in Zwift is creating a malformed .fit file which Garmin Connect is rejecting - this suspicion is based on having tried to download the original .fit file from Strava and seeing GC reject it every time.

@Zwfit devs - perhaps there is some issue in how you’re writing the .fit file, and Strava is more lenient than Garmin Connect?

It doesn’t happen always, so the process is probably correct, but I think it might be interrupted before it is finished sometimes and that causes a problem. Or there are some time jumps in the file which Connect refuses but Strava just corrects (Strava does some post-processing on the file everytime, but keeps the original file too).

thank you Erik … i’ll try

In case it helps someone - I got this for the first time the other day; The only thing I did differently to usual was to tab through a couple of steps on a workout, so I can only assume that this messes up the timing when transferring to Garmin Connect.

Running the file through FIT File Tools sorted it so I was able to upload.


These sync issues are really incredible. I did 2 rides today. First a warm-up and then a TT race. The first one synced to Strava, but didn’t sync to Connect (fitfiletools corrupt time fixer helped). The second one didn’t sync to Strava, but synced to Connect. Mind blown. Literally.

Exact same experience today. Usually no problem uploading to Garmin, but after skipping a couple of steps on a workout tonight - no garmin upload. Strava upload went as normal

I have the sync problem from last Thursday, same today, the workout are sync with Strava and Training peaks but not on connect

Still not able to sync to Garmin Connect since December 2021, have to manually down-/upload .fit file. Very annoying to say the last. Location: Switzerland.

I’ve also started to suffer from this issue. My workout correctly sync to Strava and Today’s Plan but not to Garmin Connect since May 28th.

1 Like

I’ve tried to download the .fit files from the Zwift website and import them manually into Garmin Connect. However, it seems the file is corrupted or there is an issue with Garmin Connect’s manual import service.

@shooj should I open a new thread to help debugging the issue?

1 Like

5 posts were merged into an existing topic: Zwift not syncing to Connect