Zwift Reading Cadence but not power from the same source

problem: Zwift not reading any power in app - and thus not moving.


  • Heart rate monitor and cadence are being recorded (cadence is coming from my stages crank based power meter, which is not being read for power)

  • Tried switching to my Vortex (no success)

  • tried checking my power meter for an update and recalibration. No issue and reads fine within the stage app

  • moved my other bike into a different room to avoid interference

  • disconnected all other bluetooth devices from my phone

  • restarted the app

  • Made sure all other apps were closed, and then restarted bluetooth and the app

  • Replaced the batter in my stages power meter (was showing at full strength before doing this as it was replaced this past weekend)

At a loss of ideas here, anyone had a similar experience?

Last time I used the app was Monday Morning with no issues. Since then I have had an update to my iphone (although that happened after I was having this connection issue this morning at 6:30).

It sounds like your power meter is paired to something else still. Does Zwift pick up your power meter at all? It shows it, just zero watts?