Stages Powermeter and Cadence

 My Stages powermeter stopped showing the cadence in Zwift. A reconnect didn’t help.

Are there any known issues?

Same here… I couldnt connect my garmin cadence sensor as I used to via ANT+.

As well HR monitor would not connect

Same here: Stages power & cadence showing on my Garmin and iPhone Zwift app, but not on my computer.

After the last Zwift update and a firmware update on my stages powermeter, Zwift is showing cadence again.

reviving this thread, I am also experiencing this issue, cadence is shown in the Zwift mobile link app but it’s misleading because it’s not reflecting the actual cadence

Running the latest stages firmware and Zwift software.

I have the same issue and the upgrade have not fix the problem…


I spoke with the support team, turns out this is a common issue they have been seeing with Stages PMs. After a few checks it turned out a simple battery removal and re-install that corrected the issue for me. It didn’t make sense since cadence was working with my Garmin, but regardless after doing that it’s back up and running. You have to use the search feature in both the power and the cadence sensor selections. Hope this helps. 

As a side note that mobile link app shows estimated cadence if no sensor is connected, it’s apparently going to be removed in a future version because it’s in accurate.

J B - I have removed and even changed the battery. The power is back, but still no cadence. I am tired of this technology problems and one the solution is to stop using zwift.

No cadence for me too. Please fix this problem.

I had the same problem. You have to be clipped in and riding before the cadence is sensor is displayed.

Same issue here- picks up the power no problem but not the cadence and cadence is wildly in accurate on this with the estimate

I have the same challenge. Searching for a power meter connects fine to my Stages, but when searching for cadence, Stages is not found.

My Garmin Edge 1000 has no trouble connecting to the Stages; both power AND cadence connects.

I tried to connect, disconnect. reconnect, put ANT+ reader under the bike, around three times around the house etc. No luck

Really annoying…

I think I have found a fix. After submitting a ticket and logs, I spent an hour re-reading all the previous posts on this and doing some Google searches. A few people hinted that actually riding i.e. making power while Zwift was discovering ANT+ devices made a difference. Just spinning the cranks to wake up the Stages is not enough. So I tested this out by starting Zwift and before I spun the cranks I instead got on the bike and began pedaling. All of a sudden Zwift found Stages for both power and for cadence. 

So, it appears that the cadence function on Stages is not active unless you are actually pedaling and producing power, at least for Zwift anyway. I restarted Zwift again and both power and cadence were detected again. Hopefully it will work this way each time I ride on Zwift. 

Ciao Guys :slight_smile:

I never had a problem whit my stages PM since yesterday when my cadence start for less than a second to read ZERO and Zwift start to say “SPIN FASTER” , now this problem appear every 5/10 second and training start to make me crazy :((( 

I tried to disconnect/re-connect but this still the same :((( 

I am having the same problem with my stages power meter and Zwift.  The cadence goes to zero while I am pedaling and the power stays at whatever it was prior to losing cadence.  Battery good.  Signal strength according to cycle meter app is 60% . Running app on 2017 iPad Pro at arms length of left side of bike, mirroring on Panasonic plasma tv and using Zwift mobile link app.  Reset / zeroed PM with Stages App. Cycle meter app shows no drop outs.   Also making me crazy.