No cadence or power


(Keith Studnick ztr-d) #1

Yesterday, after loading updating the software, I could pedal all I want but nothing would move. The HR worked fine. I changed my garmin battery and i tried trainer road and that worked fine but when i went back to zwift no cadence or power. When I am on the sync screen it shows cadence and power as I am pedalling but not when i click lets ride. Been using zwift for a while and this never has happened before yesterday.


(Eric C. (Zwift HQ)) #2

Hi Keith,

We are aware of the issue: https://support.zwift.com/hc/en-us/articles/205263113-10-1-zPower-Not-Reading-Bug

Hope to have a fix very soon!


(Jason K) #3

You can workaround this for now by unpairing and re-pairing your speed sensor once you’re in game.

We also found that this may only be affecting specific brands. What brand/model of speed sensor are you using? Thanks!


(Karissa Minn) #4

I’m having this same issue using a Garmin GCS 10 speed sensor. Shows speed and cadence on the pairing screen, but it won’t work ingame unless I re-pair after clicking “join” or “just ride.” Should I submit a support ticket, or is it not necessary since you’re already working on a fix?


(Wolfgang Korsch) #5

Same here. Using Garmin Ant+ dongle will show HR and cadence but no power, speed, mileage, etc.


(Jason K) #6

Just in case anyone didn’t see the announcement update, this issue was fixed in a small update last Friday. You’ll be prompted to re-pair your sensors, but it should be fixed after that. :slight_smile:

Ride on.


(Karsten Hagen) #7

Zwift gets the signal from my Pioneer via Ant+ dongle, but doesn’t register power or cadence.