Zwift Play steering left at all times

Hi, the last couple days my avatar steers left 100% of the time without touching the controllers. I can steer right and override it but when I let go it steers left again and stays in the left steering lane. The left steering paddle is not held down by anything and the left controller otherwise works. The left brake also works. Seems like a software issue? I’ve tried restarting everything, reconnecting, looking for firmware updates, etc. but nothing has worked. How to fix?

We have something which should fix this in 1.44 next week.


i had this happening also…i mostly noticed this in Watopia.

Hope the fix will work in 1.44

1 Like

Had the same issue while warming up pre-race in Watopia. Then I did a race and my right controller stopped working, so I was pulled left and couldn’t correct it. This pulled me out of the draft, and, since it was a race of 16 laps of Downtown Dolphin where you go clockwise (mainly right turns), I was on the outside of the turns for the majority of the lap. The only way I could fix it was going to the pairing screen, disconnecting steering, and then trying to join back in the race when they lapped me and doing the rest of it as a workout with a solo lap at the end. I really hope that 1.44 fixes it whenever it comes out for my computer.

This is still broken. I did a race today in Makuri and went left the whole time.

1 Like

That sucks. I didn’t have the problem when racing (8 laps of Rooftop Rendezvous) this past weekend, but I haven’t been on a ton recently (in part because of all the pains with Play/other bugs).

Are you on PC and as such back on 1.43.3? Though I did experience an aggressive steering bug on the short time I had 1.44.

No, I’m on Apple TV.

1 Like

Just done a TTT race and my avatar kept sitting on the right hand side of the screen, wasn’t able to draft at all. Was a bit annoying for my team mates I think. Hopefully it will be fixed soon. For now they go in the drawer until things are getting better.

1 Like

Yep same issue today during a race, was working fine for about 30km then all of a sudden started steering left all the time. I tried turning off the left controller but it didn’t fix the issue. I then tried turning off both controller but the avatar wouldn’t go back into the draft so basically race over. I wrote to Zwift support because I have had a few other issues and will update if they respond.

Same here since yesterday

Still not working? Have we figured out if it’s a certain route and/or type of ride?

Is this specific to the Play, or if any steering device is enabled?

Kickr bike is working.
The issue is not related to a specific event. ATM Zwift play is for me dead, could not use it… THX Zwift…money back pls

Charged my Zwift play 100% now it works

This is still broken. Took me left in Makuri on a group ride and left in free ride in Watopia. Not sure what the deal is. Seems to work okay sometimes.

It works for some minutes than steers left again.
Also recalibration does not help.

I get a replacement now fir the left controller

Same issue for me. Contacted Zwift CS and they’re ‘aware’ of the problem

Yes, happened to me this morning in Glasgow. I hoped it would be world specific so switched to watopia and the problem continued. I hoped that turning off the controllers would work but it just kept me in the left side gutter.

This is annoying because this was happening a month ago and I went through customer support. My controller wasn’t charging so go a new controller but this is happening again. It seems like a software bug.
I’m on a PC with the game in an update. Hope there is a fix soon. The play is great when it works

I did a race on Queen’s Highway in Yorkshire this morning. I disabled my steering for the race, but several people who had steering devices connected (range of devices, not unique to Zwift Play) had the aggressive steering bug at certain locations on the course.