Zwift Play & Elite Sterzo/Rizer Compatibility

If you currently have a Sterzo or Rizer there is a slight pairing issue with the Zwift Play that you need to be aware of. You should only need to follow the below once. This is relevant for Windows but potentially other formats too.

If your Sterzo or Rizer pairs in game and you then change to the Zwift Play it will not enable steering on the Play. All other functions work but steering wont.

So either turn off your Sterzo / Rizer prior to loading Zwift so it cannot pair or if it automatically pairs then unpair it and EXIT the game. If you unpair the Sterzo/Rizer and pair the Play you will not get steering. You have to EXIT.

The next time you load Zwift it should default to the Play controllers and all will work as normal.

You can still use the Rizer with the Play controllers for the front wheel elevation The Rizer doesn’t need in game pairing in Zwift for elevation to work, this is done through your smart trainer.

Oh and the difference between the Zwift Play and Rizer for steering is massive. The Play is far better, much more responsive and easier to control.

I had the same issue with my wahoo kicker bike and these steps fixed that too. Thanks!

Glad it helped

I thought this might be an issue. So I completely removed the Steerzo unit, unpaired everything and waited until no options for steering were available and then re-paired the play controllers and had the same problem. I am using Apple TV 4K latest edition - not sure if that matters. I have an inquiry into support for this as so far nothing I have tried since the update has worked to fix this. Interestingly, prior to the update I had both the Steerzo and play controllers connected (but only one controller set activated with the check mark) and the play controllers worked fine. That no longer seems to be the case since the update.

Follow-up: Tried everything again just to make sure. Even disconnected the batteries from the Steerzo since there is no on/off switch to make sure it could not connect. Restarted and exited game and then started everything again and looked for the play controllers. Everything connected fine - but still no steering function. So, I guess I will have to wait on support. Not sure what else to try.

Ok - 3rd time was a charm :). Apparently, at least in my case, there was/is a sizable delay sometimes between when everything syncs up with the companion app (necessary for the play controller connection here because of the limited Bluetooth connections via Apple TV). I waited a bit longer this time as I simultaneously watched my TV and the companion screen on my phone before starting Repack Ridge to test the functionality of the controllers. What’s a bit odd is that although the system shows full connection on Apple TV in the pairing screen it doesn’t seem to actually be fully connected in game - if that is possible. Any way, sure enough this time it worked. Definitely was not this finicky to connect prior to the most recent update - and I could easily switch back and forth between the play controllers and my Steerzo. Not sure how I feel about this. Will see how the connection and functionality works over the next few days before deciding whether to keep it or not. Off to a bit of a rocky start so far.

1 Like

Would like to be able to use the Sterzo for steering and Play for everything else. Turning handlebars is easier than reaching down to right or left bars from hoods.

But the steering using the Sterzo is much more erratic than the Play.

Im agree to your post and would also prefer the sterzo for steering. Did anybody find out how to deal with this option?


I did extensive testing an and no you can’t have steering on the sterzo artist enabling the Play buttons.

Maybe there will be a game update after a rethink of Zwift developers… i hope so.

To be honest it’s not really in Zwifts interest to enable steering on devices other than their own hardware.

I’m not sure what market share the sterzo has, I’ve a Rizer and that’s even less.

But yes as time goes on i think the Play will evolve, perhaps with programmable buttons.

I think the priority will be to iron out the connectivity issues for now along with the firmware updating process.

So you think that sterzo owners ride on an dead end…?

No entirely but if they want to take advantage of the additional functions the Zwift Play offers then yes.

It’s one of the other… not both.

Today i started Zwift (Sterzo still sleeping) with the play controller connected and started cycling. After a while i detected that steering now is possible with both devices: play controller & Sterzo . Maybe the recent update makes the difference… i am happy

I’ll look into this. Slightly confused how the Sterzo has worked if it wasn’t paired?

When was it not working and start working so i can track which update you think has affected it?

I was surprised ,too. Yesterday (tuesday) i did a race an zwift - when i started the game an update was performed (don’t know which one because nowadays almost every week updates occure). As is wrote before: today i started a training session and planed to use the play controllers. The Sterzo was in place but i did not move it before pairing the devices. After pairing the wahoo kickr, the play controlles and heart rate belt i started the training session. Coincidentally i moved the handlebar and was surprised that my avatar moved sideways. Then tried the play controller butons and doing so my avatar moved again sideways. Bingo!! :grin:

Thanks Martin, I’ll report back if this is by design or accident.

1 Like

Any update on if this had been by design or not? I just ordered some play controllers and was also going to get the Sterzo for steering (as I also prefer moving the handlebars) but if it looks like I’ll only be able to use one device or the other then I suppose I would hold off on buying the Sterzo.

Ideally, I would have hoped that we could steer with the Sterzo and use the Play controllers for everything else.

I’ve tested it today. It would appear it was a one off.

You cannot use the Play with the Sterzo