How to update Zwift Play Firmware?

No. I’m on 1.0.0

I thought that question was amity l about the process rather than the version.

no i meant updated to 1.1.0 as i dont see any update despite it supposedly being available today


Play firmware v1.1.0 is being rolled out in phases starting today, and concluding this Friday.

When it is available to you - you’ll see a notification in the home screen of the Companion app. Here are the instructions to update the Play firmware.

Is there a reason for this being staggered? It’s beta so surely all the beta testers should be on the same firmware for feed back

Same as releases as the Zwift app, by staggering it means that if that’s a catastrophic failure it affects only a few and the roll out can be paused before everybody it affected.

Makes perfect sense.


Agreed, this is the norm across the industry.

The number of times in my career we’ve paused longer than we intended following the initial 5-10% rollout to understand what exactly we are setting from the field I’ve lost count of. These things matter even more when there are millions of devices out there, and a SW Update could wipe out the IP stack (as can happen in my world), and would require customer intervention to restore. I imagine that Zwift’s brave new world of having its own hardware instead of being ‘just an app’ is bringing these things into sharp focus.

1 Like

for a tiny amount that have the controllers currently i am not sure a staggered release is necessary

Testing operational software rollout processes is definitely part of releasing a new product

Eagerly awaiting - would like to use the controllers but don’t trust them not to crash the game mid-race currently…

I wanted the update too. Right hand dropped out 5 times in tonight’s ride. Firmware stuck at 1.0

I have had the controllers for 4 days and have used them in 2 races. Everything is working fine.

My problem is connecting/seeing them with the companion app via Zwift Hardware. I’m trying to see if the firmware is up to date but every time I go into Zwift Hardware I get an Bluetooth Denied error message.

I have tried all of the suggestions Zwift advised but no success. Zwift is not open when I’m trying to connect and other Bluetooth devices are turned off. I do have the controllers flashing blue, but my phone Bluetooth does not see the controllers.

Any suggestions for a fix?

What’s the device you’re running Companion on and what did Zwift tell you to try?

I use an iPhone 12 Pro with companion. The below is from Zwift’s Support page for Zwift Play. I did pair the controllers with Zwift before trying to pair with companion. I later saw a video advising to pair with companion first so if this is a required order I did do it incorrectly.

Issues Updating Zwift Play Firmware

If you’ve attempted to update your Zwift Play firmware and it failed, here’s some things to try:

  • Verify in your app store that you’re using the latest version of the Zwift Companion app.
    • If there’s an option to update Zwift Companion in your app store, please update and then retry updating the firmware.
  • Restart the device running the Zwift Companion app.
  • Ensure your Zwift Play isn’t paired to any other device.

The LED will flash blue when ready to pair, if the LED is solid blue, the Zwift Play is already paired to a device.

  • Ensure Bluetooth is enabled on the device running the Zwift Companion app.
  • Ensure the device running the Zwift Companion app is fully charged or is plugged into AC power.
  • Ensure the device running the Zwift Companion app is within five feet of the Zwift Play.
  • Ensure the screen doesn’t timeout on the device running the Zwift Companion app during the firmware update process.
  • Force close the Zwift Companion app, then retry updating the firmware.

Don’t uninstall and reinstall the Zwift Companion app.

Still have questions?

Ride On.

-The Team at Zwift

I also followed the instructions that show up in the error message that comes up in Companion when I select Zwift Hardware.

If you go into Settings on the iPhone, scroll down and tap on Companion in the list of apps, do you see Bluetooth permission enabled like this?


That was it. Thank you for taking the time to help me with this. Much appreciated.


@shooj I recommend updating this document with info about iOS/Android Bluetooth permission settings

1 Like

I updated to 1.1.0 on both controllers fine… but now I no longer have steering. Nothing worked at first, no buttons, no paddles. I rebooted the devices, game, and ATV. Connected my Sterzo for a while and then reconnected the Play controllers. Buttons started working again… but still no steering. Took batteries out of Sterzo, no change. Noticed that brake lights work on both paddles, just no steering. Contacted support will report what they say. Hope there is a “factory reset” sequence somewhere :wink:

This sounds like this could be the issue

Support got back to me very quickly! They pointed me to an article, Calibrating Your Zwift Play on how to calibrate the controllers. Followed the instructions and everything working again!! Thanks Zwift!!