Zwift PC software so annoying, now 1Hz refresh rate!


It’s been great to ride in the Zwift world, but the way Zwift does its software is so damned annoying. Why is it necessary to force the user to update the software right away? So many times I try to join a race or group ride ending up forced to do software upgrade ending up missing my warm up or worse yet the start of the ride! Is that really necessary? Can’t they give the user at least a short time window to update? I have been putting up with this BS but now I am mad.

About 4 weeks ago after updating the game software, I got the error message saying I need to update OpenGL software (I couldn’t recall the exact message) and the game won’t start. Of course missed the ride all together. After much search on the web, I found the Microsoft OpenGL/OpenCL compatibility pack. After installing that, I can start the game but now it was super slow and completely unusable: the screen frame rate was about 1Hz! I should emphasize that the game was running perfectly fine until this update. This slow running happens right away after the launcher starts the game, i.e., when the game animates the big Z with that little thing riding the bike, even before getting into the search screen for the trainer, heart meter, etc. The CPU load goes immediately 100% (over 95% for zwift).

While debugging this issue, I have updated the Nvidia driver to the latest version. I have also checked that I have DirectX12.

Zwift support has so fart provided no useful info to solve this problem after a few email exchanges.

The PC setup I have:
Windows 10 (clean install, no junk software)
Lenovo i7 laptop with 32GB (2017)
Nvidia Quadro M2000M

Would most appreciate any suggestion what I can do to get zwift running normal again. I am thinking to completely reinstall Windows 10, may be installing the OpenGL/Open CL compatibility pack was not a great idea since from what I read games should be using DirectX if version 12 is present.


The Microsoft OpenGL/OpenCL compatibility pack is used for software graphics accelleration so it will use the CPU rather than the GPU, which isn’t designed to do the graphics. So the first step is to uninstall that. If you have updated the Nvidia drivers to the latest version that should have updated the OpenGL software to the version required by Zwift.

And make sure you check here and your companion app for news of updates.

That way you can login with plenty of time to update which in reality takes a couple of minutes normally.

Even without knowing there’s an update it’s well worth logging in before you put your gear on, fill your water bottles etc…
Swap your cycling preparation procedure and you’ll be fine.

Thanks Michael!

I have uninstalled the OpenGL/CL compatibility pack. Now I got the original error:
Zwift error 2023-05-07 203846

I have checked that my display drivers are up to date:

I double verified the Nvidia driver is indeed the version that I just downloaded, and it has DirectX 12:

So somehow Zwift can’t find the DirectX 12 on my PC? Any suggestion what to do next?

Thanks for your help!

Hi Stuart

Yes, I have been making adjustments to my ride preparation to accommodate Zwift, but it shouldn’t need to be that way. And I endured. But this last time has been a months, I still don’t have Zwift running. That is hell lot longer than 2 min :frowning:

I do appreciate your suggestions though, thanks.


Are you linking to a television?

Not linked to a TV, I am running the game on the laptop whose screen is the sole display I use. The problem is, I have not changed anything on this laptop between the last time I rode when everything was fine and the upgrade that broke it.

I get that. There are sometimes Windows updates that coincide with Zwift updates and makes it look like Zwift is the issue.

Not saying that is the case here.

Out of interest try changing the resolution you are running on the laptop and see what happens.

On this laptop, it appears I can only run the display at the native resolution of 1080x1920. In display menu, the Display resolution dropdown menu is disabled :frowning:

BTW, there was a windows update pending. I didn’t installed it until after the problem occurred, thinking may help.

I’m very out of the loop on Nvidia graphics cards and their drivers, but Official Drivers | NVIDIA suggests 528.95 is the latest WHQL driver than supports your Quadro M2000M.

Hi Steve, good catch, I don’t know how I didn’t get the latest. But unfortunately, after updating to 528.95, same error persists :frowning:

Is Microsoft Basic Display Adaptor still there ? If so get rid of it.

I have a Lenovo W520 with Quadro 1000M and Win10 Pro, it works fine with Zwift.
Driver version 353.62

1 Like

Have you checked the NVidia settings to make sure its using OpenGL and hardware acceleration eg

Thanks Neil for your suggestion.

When I uninstalled the Microsoft Basic Display Adaptor, the Zwift reacts worse: instead of giving the error message, after I hit “Let’s go” at the launcher, it go to a white window for the game and stuck there until I close the game window.

In the Nvidia control panel, I have also set the “Preferrred graphics processor” to Nvidia instead of the Intel integrated or vice ver sa, it made no difference from the default setting which was Auto.


Thanks Donald – I followed the link but the multi-display selection is not present on my computer. Perhaps because I don’t have monitors attached to the PC?

It does have two OpenGL related items, “Open GL redering GPU” and “OpenGL GDI compatibility”. I tired each of the possible selections in them, none made any difference – still getting the same error.


I have my integrated graphics disabled in BIOS so Windows only sees the Quadro, can you do the same ?

I set it to “discrete” which should mean Quadro. It made no difference. Still the same error. :frowning:

The latest in case it may help somebody else:

Have been working with Zwift support and tried various stuff they suggested. Nothing worked about 6 iterations of emails.

Then I got a notification for a windows 10 update – after installing that zwift is back! It appears that for all these time, I have not been using the Nvidia graphic card. With the graphic card selection forced to Nvidia instead of the integrated graphics (Thanks Neil!) now the graphics looks very different than before – much more 3D like. So I got some benefit out of this ordeal.

Thanks to Neil, Donald, Steve, Stuart, Michael for trying to help!


And an apology to Zwift?

And another?

Glad you got it sorted.

1 Like