Zwift needs OpenGL update since trial has ended, so i cannot start it up.

Hello, My Zwift was working perfect last night, this morning i try to go on and now its coming up with  the message about drivers needing updating for open GL 3.1 or higher, I have updated all my drivers so there shouldn’t be a issue, but i still cannot get on. Does anyone have a work around as i want to do the ride london challenge :-/

Have you restarted your machine after updating your driver? If yes, please try reinstalling Zwift. 

Hey, yes ive done both sadly and still the same result :frowning:

Hmm. You can book  a support ticket with the log files. Alternatively, I would post on Zwift Riders Facebook page and I will bet that others might have had the same issue and solved it. 

Ok thank you, ill see if anyone can help :) 

Hi, did this get resolved? I am now having the same problem, after years of happy Zwifting. I’ve checked and updated all my drivers and I’m still getting the same message asking me to update my drivers to run OpenGL 3.1.

I’ve sent emails to the Zwift support team but I just get automatic responses saying “we will reply” - and no reply! Please help! I’m pretty close to deleting Zwift and going back to TrainerRoad to be honest - I loved Zwift but it won’t keep me fit through the winter if it won’t work :frowning: