OpenGL 3.1 error [SOLVED]

Zwift has been working fine on my PC, but one day decided to not start due to an error message stating that I need OpenGL 3.1 or higher. The error message suggested that I update my graphics driver, but my driver has the optimal version according to diagnostics that I ran. Furthermore, while it states that Zwift needs OpenGL 3.1 or higher to run, according to my AMD diagnostics, I currently have OpenGL® Version , which appears to be higher than 3.1.

Any ideas? Zwift support was no help at all. They just kept telling me to update my already updated driver. I guess that is only going to get worse now that they have laid off more of their work force this week. It seems that my “support” was just reading off of a FAQ or something and not a real support tech. I have already cancelled my subscription and am currently using Wahoo Systm, which I like, and may check out Rouvy, but I’d like to figure how to get Zwift working in case I decide that I want to go back one day

There is no such thing as OpenGL, the latest version of OpenGL is 4.6

There are quite a few previous discussions about the OpenGL 3.1 error on the forum. Here’s one that has some things to try.

Okay. I do not have a clue about Open GL stuff, never heard of it until the error message popped up. I looked at an AMD diagnostic on my PC and it stated “OpenGL”; that is all that I know.

Hi @Danny_Lankford

When we see the open GL 3.1 error, generally this means that your graphics drivers are out of date. In the times where the driver isn’t out of date it’s very likely that there is an issue with the graphics driver itself. My best suggestion is to try reinstalling the driver just to be sure. If you are still having issues after that, the best thing to do is to send a copy of your launcher log files to our support team so we can take a better look at what’s going on. If you need help getting those log files, this Zwift support article has the steps to gather them.

I encourage you to attend to the suggestions in the thread I mentioned above and report back

It appears that I fixed it. I use a TV as my monitor; I changed the refresh rate on the TV and now Zwift opens up fine.

1 Like