Error: Zwift requires OpenGL 3.1 or higher to run.


(Jeff Fourman) #1

I started Zwift this morning and it automatically installed an update. Upon restart and clicking Ride, I received the message "Zwift requires OpenGL 3.1 or higher to run. I have been playing Zwift on this PC and TV for months with no problem. I have updated all drivers, run Windows update, reinstalled Zwift and restarted the PC multiple times without resolving the issue. Zwift worked fine 2 days ago.

My config:

  • Windows 10 Enterprise version 1703 - Core i7-7700 (Windows up-to-date)
  • EVGA GTX GeForce 1080 TI SC2 (NVDIA and EVGA Drivers up-to-date)
  • TV - Samsung UN65MU8000 4K connected via HDMI

I’m idle until I get this resolved. HELP!!! …please.


(Jeff Fourman) #2

SOLVED: I figured it out. I forgot that I had recently turned on the “HDR and advanced color” feature on my PC Display Settings. Turning off that feature solved the issue. My Samsung UN65MU8000 4K TV supports HDR. Would anyone know an explanation of why turning on this HDR feature would cause the OpenGL error?


(John Larson (LAPT)) #3

I ‘think’ turning on HDR may cause the graphics driver to use a different rendering library than OpenGL. Just conjecture on my part, though.


(John Watson) #4

I’m having the same issue, HDR has never been an issue in the past. This has something to do with Zwift’s latest update. I did a workout Tuesday and had zero problems launching the game. I went ahead and opened a ticket.  I have a i7700k, 1070gtx, 16gb ddr4, and run on a LG c6 65. 


(Jeff Fourman) #5

John Watson: I opened a ticket; but then updated the ticket to say I solved the issue by turning off HDR. It’s often hard for me to recall the sequence/timing of when something last worked in relation to the last tweak. I agree with you that until today’s “Update”, Zwift worked fine with my PC setting of HDR On. Please update us with the response you get on your ticket.


(SINAN AVCI) #6

Today  have the same issue. I did not play with the screen settings,but played with the zwift settings to decrease the battery saving, that is all. Now I can’t go back and resolve the issue. Any idea?


(Joachim Vogt) #7

I can conform that I have the same issue since the update. Before, I could run Zwift without any problem on my Lenovo netbook with a HDMI connection to my tv set. Does anyone know when this will be fixed or what would be a turnaround.


(SINAN AVCI) #8

Problem solved. I had also opted for full window from the settings. I changed that and everything is fine again. 


(Brent Fidler) #9

I too am having this problem.  I have tried everything mentioned in this thread to no avail.  My computer was running Zwift without issue until it installed an update on 2/15/18.  Now I get the OpenGL 3.1 error message.  I have changed no hardware.

I have updated the latest drivers on my NVIDIA GeForce GT 430 graphics card with the latest Windows 10 Drivers.

I changed all settings in the NVidia control panel to default to the NVidia Graphics card.  I changed all settings in the NVidia settings for everything I saw in the control panel to performance. Still no luck.

I uninstalled and re-installed Zwift with no luck.

After re-installing I went back and changed all the items in NVidia control panel as I did before reinstalling with no luck.

I submitted a ticket on 2/15/18 and still have not heard an actual response aside from the automated one.

I have become dependent on Zwift!  I am at the point I don’t want to ride my trainer without Zwift!  Getting frustrated.