Open GL 3.1


(Mitch De Jode BZR) #1

After hooking up my pc to my flat screen tv I got the message that Zwift requires Open GL 3.1 and that I should update my drivers. The moment I go back to my regular pc screen it works again. 

Had to delete Zwift folder in the documents map. And now i’m forced to play windowed. You guys aware of the issue?


(Jon Mayfield) #2

Sounds like you might be on a laptop that has multiple graphics cards. Do you know if that is the case?   If you dont’ know, you could attach your Documents/Zwift/Logs/ComputerSpecs.txt file or let us know what exact model # of computer you have.

Some laptops might disable the built in graphics card when plugged into a 2nd monitor or TV, and in that case the driver you might need to update is the Intel graphics driver.  


(Mitch De Jode BZR) #3

It’s my old gaming rig with hdmi output to a TV. Attached the file. Only one 5770 inside.Saw a discussion on Zwift Riders fb group earlier and some had the same problem.

 

Edit: Looks like attachment didn’t work, here you go.


(Mitch De Jode BZR) #4

Did the test. Swapped GPU’s around 6970 same error when going full screen. PC monitor no issues. So it has something to do with my tv. Can’t figure it out :frowning:


(C live Goodwin PACK) #5

I’m having this issue too; It is definitely something to do with the Panasonic42" Plasma screen I am using to view the ride & not the computer hardware/software… 


(Mitch De Jode BZR) #6

Solved my issue tweaking the texture setting in my control panel from my video card. Changed it to performance. If you don’t have integrated graphics. That did it for me :slight_smile:


(C live Goodwin PACK) #7

Spot on! Worked for me too!

Well done for finding this :slight_smile:


(Mitch De Jode BZR) #8

Build another rig. FX4300/7950 using latest crimson drivers. Same error, older drivers nov 2015 fine. Unfixable with crimson drivers.

100% Zwift problem.


(Mitch De Jode BZR) #9

Another update for AMD users. If the Performance trick doesn’t work.

You can set display profiles in the control panel. Make sure they match. Crimson tends to upscale some displays to 1440p while they are in fact 1080p -> that gives the OpenGL error.

So sorry zwift, for blaming you. It’s AMD being bad. No issues with nvidia cards so far.

 

(Oh yeah, I build pcs. That’s why I’m testing all those GPU’s)


(Brad Spurlin) #10

Hope someone can help a complete tech newby.  I purchased brand new Alienware Alpha as recommended by Zwift.

Have it plugged into Panasonic Plasma 50’.

Get the UH OH pop up saying error needing OPEN GL 3.1 needed.

Appreciate any guidance.

Thank you in advance


(Mitch De Jode BZR) #11

Should be an nvidia control panel bottom right of your screen. In there you can change display settings make sure its 1080p with the correct refresh rate.


(Jerry Weiss) #12

having the same problem as Brad with my brand new alienware machine.  It came installed with the “Microsoft Basic Driver” for the graphics card.  and it won’t allow me to change the resolution.  Does anyone know how to install OpenGL 3.1 ?

 

There is no NVIDIA control panel on the lower right in Windows 10.

I got no “UH OH” pop up. Zwift just crashed. but the log file says : "

|

GLFW ERROR 65542: WGL: The driver does not appear to support OpenGL"

|

 


(Jerry Weiss) #13

Mitch - where is the “control panel on your video card” in Windows 10.  all I can find is display settings, which doesn’t have at texture setting


(Jerry Weiss) #14

OK - I went to dell product support and installed their auto-detect software and checked for updated drivers.  It said I needed a new intel chipset driver so I downloaded, installed and restarted and now Zwift works. Don’t know if I’m getting the most out of the GPU or how to check it, but at least it runs.


(Mitch De Jode BZR) #15

If you have an nvidia card you need these drivers:

http://www.nvidia.com/Download/Scan.aspx?lang=en-us


(Jerry Weiss) #16

Thanks - I will try that as well. Seems to be working after scanning from the dell support site and updating the intel chipset driver and restarting.


(T KC) #17

Ok Gents, I ran into the same issue. Zwift runs fine on the comp display but when I try to extend it to the secondary monitor (TV) it gives me the OpenGL error. I’m running AMD Radeon HD7310 on Win 10, could this be Win10?
I can not find the texture settings (Mitch mentioned) anywhere in the Catalyst.
Any suggestions? Much appreciated.


(. EDIT ZsunR..) #18

HELP!!! Am not computer savvy at all , my alienware alpha arrived yesterday , i have the i5 model , and it worked no problem yesterday , but today i am having “zwift requires opengl 3.1 or higher to run” , it did run some kind of graphics update today and also hooked it up to new tv (not sure if that makes a difference)


(.. Tears For Gears.. (C)) #19

After nine months of no problems, I had the Open GL error. Reinstalled Graphics Drivers and Zwift. Still the error. Then read about the resolution needing to be 1080p. I don’t know why it had changed, but it had. All sorted now. I’d check that first before reinstalling drivers.


(Chris Barnard) #20

Just had this happen to me when I changed the setting in Zwift to full screen from windowed . Changed it back to windowed all good again phew !!