Error: Zwift requires OpenGL 3.1 or higher to run

Hi,
I’ve been facing this issue for some time. It made me go crazy, I’ve even been thinking about quitting Zwift because of that. But last weekend I spend an afternoon on debugging this and fortunately I was able to figure things out.

On my laptop I’m using Ubuntu 20.04, however I think this may be more driver related issue and to get rid of this Error popup and make Zwift starting and operating properly all you need to do is to locate “prefs.xml” on your computer (it is a xml file with Zwift settings saved in it) and remove line:

“<PREFERRED_MONITOR>2147516416</PREFERRED_MONITOR>”

without this line Zwift doesn’t show up any error messages and works ok, unfortunately this must be done before every Zwift ride (but I think it is not a big deal to prepare some automated script to remove that line)

Quitting Zwift because it throws an error message on an unsupported platform seems a bit weird, but glad you’ve found a solution to your problem.

2 Likes

I think this is quite common issue among zwifters, additionally I’m working on that platform so I didn’t consider any trasformation to windows.

It’s not common at all, since it only requires a display adapter from any time in the last decade to overcome.

Your issue is presumably that Linux reports adapter capability in a way that Zwift cannot recognise… But Linux is unsupported so that’s no real surprise.

1 Like

What display adapter might someone need to resolve this issue? I have Windows 10 and am having the same error. I don’t know any workaround though so I just can’t use Zwift on my PC.

The OP’s problem was probably to do with running the game on Linux. If you’re on Windows you shouldn’t be having any issues.

Would need to know your system specs to provide better help but ensure you’re outputting in a native resolution with progressive scan format. Interlaced tends to generate this error message from Zwift.

I’m getting the same OpenGL Error on my Windows 10, running AMD RAdeon 590 with Intel i7-6700, and 16B of DDR4…
I can’t open Zwift…

Are you using a TV? Ensure the Radeon driver is outputting in progressive scan format.

Have you checked what Dave suggested in the reply immediately above yours?

I’m try that! It was working fine last week, but who knows! 🤷🏼 maybe something changed :sweat_smile:
Thanks for the suggestion!

Resolved:
The Monitor was plugged into my primary display output (needed to improve home office/Zwift performance room layout), and with the monitor plugged into my Radeon port, apparently the i7 CPU couldn’t handle the Zwift graphics…? Doesn’t quite add up, but by switching over the HDMI outputs, I can now run zwift, so…

Ha, yeah you definitely need to be plugged into the graphics card not the motherboard. :wink: It would have worked, but with tremendously crap graphics by comparison.

Hi!
I had the same problem today and found two fixes:
1.If i changed to “Fullscreen from 1 to 0” in prefs.xml it worked.
2. But the real fix was setting the hz refreshrate on the connected monitor.
right-click your desktop and choose “display-settings”, Scroll down and choose advanced screen settings and then change the hz.
Mine was set to 30hz and then i got the error with Open GL 3.1, after changing to 60hz it worked like it should in fullscreen again.
I hope this helps someone :slight_smile:
Ride on everyone :slight_smile: