Open GL 3.1 Issue

For some reason I am having an Open GL 3.1 error when trying to run zwift. I’ve read the archives and they are old. I have never had this issues in the 3 years that I’ve been on Zwift. My drivers are all up to date. I have been able to contact support once on this and the solutions offered all don’t work. I have not been able to contact Zwift Support at all since. Very confusing and frustrating. These are my specs.

GPU - Radeon RX550/550 Series - Discrete
VRAM - 4096 MB - GDDR5 1500 MHz
Graphics Card Manufacturer - Built by AMD
Graphics Chipset - Radeon RX550/550 Series
Device ID - 67FF
Vendor ID - 1002
SubSystem ID - 0B04
SubSystem Vendor ID - 1002
Revision ID - FF
Bus Type - PCI Express 3.0
Current Bus Settings - PCI Express 3.0 x8
BIOS Version -
BIOS Part Number - 113-55D-XGE
BIOS Date - 2019/01/17 05:00
Usable Memory Size - 4096 MB
Memory Type - GDDR5
Memory Clock - 1500 MHz
Core Clock - 1071 MHz
Total Memory Bandwidth - 96 GByte/s
Memory Bit Rate - 6.00 Gbps
2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/CurrentControlSet/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0001
OpenGL® API Version - Not Available
OpenCL™ API Version - 2.0
Software Version - 2021.0824.1855.34051
Driver Version -
Provider - Advanced Micro Devices, Inc.
2D Driver Version -
Direct3D® Version -
OpenGL® Version - 29.20.11000.14742
AMD Audio Driver Version -
Vulkan™ Driver Version - 2.0.193
Vulkan™ API Version - 1.2.182
Windows Version - Windows 10 (64 bit)

Firstly ensure your computer is using the RX550 for video output and not the integrated graphics. Ideally disable it in the BIOS, to be completely sure. I’m assuming your display cable is plugged into the graphics card but some iGPUs can run alongside the dGPU and this can confuse Zwift.

Then go into the Radeon driver and ensure your output resolution is native, and using a progressive scan format (e.g. 1080p) If it’s set to interlaced (e.g. 1080i), Zwift throws the OpenGL error.

Thank you for your response. How do I disable RX550 in BIOS? I am not so tech savvy.

I meant you could disable the integrated graphics in BIOS, not the RX550. Check the driver settings first anyway, you may find it resolved easily.