Zwift on PC with Ethernet and ZC on Phone on Wifi

Hi, I am having trouble connecting my Zwift Companion app on my phone and my Zwift app on my PC. My PC is connected via ethernet cable to my router, while the phone is connected to the same via WIFI. Anyone have the same issue?

I run my ATV via ethernet and my Companion App on my phone on the same wifi network - no problem.

Does it work ok when your PC is just on wifi?

I dont have a wifi card on my PC so I cant try it, unfortunately.

I use this setup with no issues. Ensure your phone is configured to only use WiFi for data, rather than both WiFi and cellular. On Android this is called Smart Network Switch, on iOS it’s WiFi Assist.

I just tried turning off my mobile data and still doesnt connect. Thanks for the suggestion though.

I also have the same setup and it works without problems. Is it possible that you are connecting to a “guest” network on your router? These are normally configured to isolate traffic from the rest of the network.

What is the IP address of your PC? What is your IP address of your phone? It is ok if they are on different subnets as long as traffic is allowed between them.

You could try statically assigning IP addresses to both devices and see if that works. If that works you might have to see if your router can do DHCP reservations so you wont have any issues using different WiFi networks with your phone.

I have been running that setup for years without issues.


I had the issue that even on different subnets and traffic allowed, it would not work, it was not until the PC and Phone were on the same subnet did it work for me. Based on my pfsense firewall, the app was not even trying to contact the other subnet, my PC.

1 Like

Based on research, I actually think it is my network providers router that is not allowing traffic between ethernet and the wifi slots. I have the same problem with printing on our wifi printer from my ethernet PC. Thanks!

How is your router set up? Does your ISP router let you do VLANs / separate subnets for wired vs wireless?

When I check network on ATV it simply shows “ethernet”. How to make use SSID for Companion matches the ethernet network name? (My wireless is via an access point connected to the router, btw)


My post wasn’t to do with Apple TV. This thread is about PC, and I was talking about a change you make on your phone. :+1:

You are basically talking about 2 different things. When it says “ethernet” it is just a name for your wired connection and will not match the wireless SSID.

1 Like