Companion app

Companion app doesnt recognise ethernet connection. As soon as I disconnect the ethernet connection and put wifi on companion app loads up fine. Connection is not the best so I was trying to enhance my wifi connection. The internet and everything else on my phone works perfectly fine with the ethernet connection

How are you plugging an Ethernet cable into your phone?

It’s an Ablewe USB C hub adapter from Amazon. I just dont understand as it works perfectly and the ethernet sign comes up on my phone and its enabled and everything works fine. The Zwift mobile app works and all internet searching etc. The companion app just says no internet connection until I take it out and put the wifi on, then it loads

Are you trying to connect to the Zwift Companion App to the Zwift App on the same device?

I would suggest just using WiFi.

My issue is that I zwift in the garage so wifi signal is terrible. I’ve just got a new tv and apple tv to run zwift on and I have a tp link which connects the internet to it via ethernet cable. Apple tv has 2 bluetooth signals so I can use the companion app to pair my ble hrm to which then I connect to zwift on apple tv.
The companion app will not connect to the ethernet via my phone and just says no internet connection when there is a connection as everything else on my phone works, internet etc. If I just use normal wifi it keeps dropping out due to the poor reception which means my hrm will keep dropping out which just wont do for racing etc. Why does the companion app not work with an ethernet connection?

Pretty sure it is designed to work on the same wifi. Not connect to the internet but the wifi. I doubt the designers thought people would be plugging their phones in to the Ethernet.

Couldn’t you just use a WiFi extender in the garage. I have a couple in my house so the signal is strong everywhere.


It’s the same wifi just through an ethernet cable that is connected to a tp link which is plugged into my wall. I have 2 in the garage, 1 that is plugged directly into the apple tv which you need and one that I have with a C adaptor that’s plugged into my phone. My phone works perfectly with the cable in. The only app on my whole phone that doesnt work and just says no internet connection is the companion app. Why?

Just use a WiFi extender of if you have an old router with built-in WiFi you could use that.

1 Like

When I first got on Zwift (in my basement), the wifi was pretty weak. I did some research and settled on the Eero wifi mesh system. Just one beacon, plugged into an outlet in the basement, but close to the location of the router located upstairs where the Eero base station is connected to the router. Super easy, super reliable, super fast. Only issues I’ve had since is if I forget to turn off the VPN on my phone. Sometimes that messes stuff up, but otherwise, it’s just a joy to use Zwift. Ride On!

I can’t understand why you don’t use wifi if it is able to be used? what is the benefit of connecting your phone with the ethernet cable?

Because the wifi reception is not the best so I was attempting to attach my phone to an ethernet cable thus better reception which I actually managed but for some reason the companion app didn’t recognise the ethernet connection. Everything else on my phone was rapid but the companion app didnt even realise it was connected and just said no internet connection retry. Anyway I got a wifi powerline extender to put in the garage which I can connect the apple tv to via ethernet and get a wifi signal to my phone so it all works great now

Same problem here. Such backwards design, why would you check for an interface as opposed to an actual connection??? Companion says “internet connection is needed” (which is not true, it wouldn’t be happy with mobile data either, it needs a LAN interface but I guess words don’t matter) while I’m happily youtubing away on the same Android device. The Zwift app is on the wired network, which it’s happy with, the phone is hooked to the wired network, which it’s happy with, and Companion doesn’t use the data it just checks whether it’s connected to a WiFi device. I specifically have to turn off the Ethernet connection for it to be happy. Chalking it up under “Oh, Zwift”