Zwift on PC Crashing after latest Update

It’s not a problem with your specs.

There’s either something rogue with a recent update or we have several people with individual Windows issues.

Does anyone know if Zwift Corp., follow this blog. If so, why haven’t they said anything on what is clearly a wider problem than just a few Zwifters. Surely, they should say something, even if it’s to say they’re aware and are looking at it. I fear Zwift simply don’t care, many will decamp to another provider swich as BKool or similar. Interesting to note that Zwift has lost the UCI contract to a newcomer!

1 Like

*such as BKool.

A Zwift staffer already replied to you above and asked you to take this to Zwift support for close examination. Have you done that? The reply is at Zwift on PC Crashing after latest Update - #6 by shooj

The reasons behind that have been covered in another thread.
Wait and see if it happens.

Same here. Five out of the last six sessions on my PC have ended in a frozen screen and a crash to desktop. Removed and reloaded the program multiple times.

The platform seems stable for a while and then an “update” will just introduce chaos.

Frustration level 11.

1 Like

Steve., thank you yes, I noted that. The point I’m making is that a) this is clearly a wider spread issue than first thought and, hence, b) something Zwift need to address groupwise not on an individual one-by-one basis. Secondly, Zwift could make life a little easier by providing the relevant link, if each individual is going to take up their own cause, but it should not come to that given it’s of general interest to all PC users. Lastly, this comes down to customer care, Zwift should want to take the initiative rather than asking a Zwifter to lead the charge.

1 Like

Hi Andrew,
I received a suggestion from Zwift that seems to have worked. I was able to bike for 2 hours yesterday. I want to bike a few more times before I say that the solution completely worked.


I completely agree with you. I also struggled with the same thing. It was solved by turning off the video capture suggested in this forum. The Zwift team just thought it was a user PC problem.

oh!! Great. I’m really looking forward to seeing what the solution is.

I’ve been getting this a lot, sometimes it takes me 2-3 attempts to load into a world without Zwift crashing. Crashes always happen within the first 1-2 minutes for me and if it lasts longer then everything is fine.

I don’t get black screens or anything but I’ve noticed when Zwift crashes it also takes out any videos playing in a Chrome tab so I’m guessing it’s a conflict with the video capture feature and other apps which also use hardware accelerated video playback. I would recommend closing Chrome (and any other browser based apps like Spotify) and then loading up Zwift. Once Zwift is settled reopen Chrome.

I have an RTX 3070 so it’s not just some weird integrated graphics bug.

Hi Gondaddy and all,
I have not biked consecutively for 2 hours since, however I have been using zwift without incident. I may still not be out of the woods, but I did the following. To all those who suggested I wipe the computer clean and reinstall Windows 11 etc, which would take hours, I did the following twice, and it seems like a less drastic operation…and you were right, it was windows 11 (my apologies to those I disagreed with)…corrupted files…which seemed to happen during/after update 1.44.2?

System file corruption – As it turns out, this particular issue can occur due to system file corruption. If you’re getting constant Event Viewers with this error, you should be able to resolve the issue by repairing Windows files and fixing logical errors with a utility like SFC or DISM.

Enter CMD in the search bar of Win + R key to find “Command prompt”, right-click to open it as an administrator, copy and paste carefully, and execute the following commands (network operation is required, one line at a time)

      DISM.exe /Online /Cleanup-Image /ScanHealth

      DISM.exe /Online /Cleanup-Image /CheckHealth

      DISM.exe /Online /Cleanup-image /Restorehealth

      Regardless of whether the above three commands display errors or success, finally type the following command: 

      sfc /scannow

     Once the scan is complete, do a final system reboot and see if the issue has been resolved once the next system startup is complete. 

This process may need to be repeated once or twice.
This is from a microsoft forum, that zwift had redirected me too.
I hope this helps.

Vivian, thank you for this. I’ve run the CMD lines on both my Surface and Gaming MiniPc and will let us all know if the problem is still there. I’ve not had a crash for a week or so but did have a screen go black for a couple of seconds, but recover (just as well because it was near the end of a particularly hard pyramid session!)

1 Like

Since the August (?) App update I had been experiencing problems with the app crashing during rides, the app becoming unresponsive when saving or exiting (evey single time this happened), the app freezing and other such issues. Prior to the update all had been fine, was using the same windows 10 laptop I had used for ages.

Zwift support informed me after sending crash logs that it was likely a Bluetooth issue but this didn’t seem likely (no power or connection drop outs) and the proposed fixes did not work

Last night I disabled the video screenshot function and immediately I could exit the app properly with no issues. This morning I was able to ride unaffected. So that one quick fix seems to have resolved my problems :slight_smile:

I had thought it must have been something to do with the most recent app update and the video screenshot function seems to have been rolled
out to my laptop around then time, so I makes sense

Many thanks!

1 Like

Video screenshots has caused many issues that it shouldn’t have to the point it’s the first thing i suggest turning off when diagnosing issues like yours.

I don’t wish to tempt fate, but I’ve not experienced this crashing issue for some time (although the screen sometimes goes black but, has to date, reappeared shortly after - and not fully crashed as it did a while back since 1.45 update hit the platform.) This still seems to be a widespread issue that Zwift don’t seem to resolve (slightly worrying that they have said it’s a Bluetooth connection issue when they know about this issue and it’s clearly not due to Bluetooth - it happens via Ant+ too.) Incidentally I ran the scrips via Command Prompt provided Vivian above as belt and braces. Having to switch off a feature of the game can’t be the answer, the whole game with all features should run on PC (as well as Apple.)

It should but for some reason it causes random issues on certain setups.

It’s part of the reason the initial roll out was pegged back to certain processors whilst testing continues.

There doesn’t seem to be a common denominator though which makes it hard to work out why it’s an issue.

Could be video driver, Windows updates, specific hardware.

working on this now on my Windows 11 laptop. my Windows 10 and my hubs Windows 10 seems to be unaffected (for now at least). i ride seasonally, so i Zwift mostly when the weather turns cold but i keep things updated during my inactive time.
we made sure all 3 laptops had latest Windows updates before updating Zwift to latest greatest last night. the 2 Win10 laptops are fine. my Win11 is showing the freeze similar to what im hearing here. all im doing is launching the app, select to Just Watch since im not riding and just making sure the app launches correctly. there is no BT, etc connecting to anything. app launches fine, i click Back to Me | Menu | End Ride and try to select either the Trashcan or Saving options, it freezes and i have to End Task through Task Manager. before finding this specific thread, i verified my Defender Firewall settings are fine and i uninstalled and reinstalled the app 3 times, making sure nothing Zwift related was running in the background. several reboots as well after uninstalls and reinstalls.
i found this thread so i relaunched the app and went to Settings to Disable the Video Screenshot option, but when i click OK, it freezes at that screen too and again i have to End Task.
i have twice run the DISM.exe commands and reboot as mentioned above and rebooted and the results are the same, still hanging on Trashcan, Save, or OK after selecting Disable on the Video Screenshot option. i cannot fine a .cfg or .ini file where i can toggle that off instead of trying to do it through the app - which is bizarre since i used to work in IT and every app i ever installed on a server has some sort of cfg or ini file where settings could be adjusted manually
i will keep monitoring this group and topic and hope Zwift issues and update for this

yep Video Screenshots is a major culprit. here’s what i just tried:
uninstalled Zwift → reboot
ran DISM.exe commands & SFC command → reboot
installed Zwift → reboot
launched Zwift and let it update to latest (1.51 at this time)
launched Zwift → Just Watch → Back to Me → Menu → Settings
changed several settings back and forth like Unit of Measurement, Language Filter, etc., clicking OK and going back and forth making sure it didnt hang.
changed Video Screenshot to Disabled, clicked OK and it is Hung again

so other than copious troubleshooting, there is no user configurable resolution for me

i found the fix for my Video Screenshots issue. after posting to the /zwift Reddit group, a user advised editing the prefs.xml file for <video_capture_enabled>1</video_capture_enabled> and setting that to 0. after doing that i launched the app and confirmed in Settings that Video Screenshot was now set to Disabled. i then backed out to the Trash Can/Save screen and selected the Trash Can and it worked taking me to main options screen where i could then Exit. hope this helps others!
also, note that the Video Screenshots option was pushed out to certain processor levels, not necessarily and OS version issue. the processors are listed in a Zwift Insider article and i was able to confirm my affected laptop has a processor in that list.

1 Like