Zwift Keeps Crashing on Loading a World

Hi All,

Since Friday last, every time I try to load Zwift on a Windows 10 PC, it crashes.

I have updated to the latest SW version, but still no improvement.

The application loads ok, it allows me login, but when I click ‘Ride’ it crashes out.

I have been able to use it successfully on an iPhone but I need it working on my PC.

Any ideas?

Thanks,

Jason

Hi @Jason8824_Corbett, can you give us some more info on your problem? Where exactly is it crashing, is it during the initial launch of the program, or are you able to log in, choose a route and world to ride in, and then it crashes?

2 Likes

Hi Mike,
Yes, it allows me to login, connect to my Kickr, but when I try to select a route or pick the default route and click ‘Ride’ the app crashes.
Thanks,
Jason

@Jason8824_Corbett have you tried re-installing Zwift?

@Paul_Allen any ideas here?

Yep, I have reinstalled it on 3 occasions now. Same result each time.

What are the specs of the PC?

When you uninstall Zwift are you also deleting the folders/files in\Documents\zwift and Program Files (x86)\zwift?

You might want to copy the files from \documents before deleting them.

1 Like

A bit unclear wrt “crash”, as there’s no visual.

However, have you tried the event viewer?

Good luck!

When uninstalling, I am not removing the files. I assumed (obvs wrongly) that the uninstall program would do that.

The laptop is a HP I5-7200 CPU x64 running Windows 10.
I use it for much higher demanding apps for work with no issues.

Appreciate the input guys.

I’ll remove these folders now and reinstall.

Cheers,

Jason

What is the GPU in it?

1 Like

When I say ‘Crash’ I mean the application shuts down.

I haven’t tried the Event Viewer but will try that also.

Cheers,

I am guessing you have the Intel HD Graphics 620 which should work just fine, that is what I have in my Zwift Running laptop. I would recommend that you close ALL unneeded programs, including some of the ones in the System Tray if they are not needed during Zwift. The 620 does not have dedicated memory so it has to use the RAM in the laptop.

1 Like

Yeah, it’s the 620 Graphics card.

Ok, so uninstalled the App, deleted all Zwift related folders and now it appears to be launching ok.

Will put it to a full test later and report back.

Many thanks all. Really appreciate the tips, guidance and advise.

Cheers,

Jason

2 Likes

Hi all,

The app worked perfect this evening after the uninstall, folder deletion and reinstall.

Hopefully it will continue to behave.

Thanks,

Jason

1 Like