Zwift not responding

Since the most recent update, I cannot Ride.  When I hit the ride button after all the devices (Garmin HR ANt+ Strap, Giant built in ANT+ cadence sensor, and Wahoo Kickr) are paired, I receive the Zwift not Responding dialogue at the top of the page.  Interestingly, I am able to Just Watch others ride.  A week ago, everything worked fine.  Tried to just use the Kickr and cadence without HR monitor, but without any luck.  since the Kickr is new, I went back to my  old Kurt Kinetic Fluid trainer, but still no luck.  the Zwift.exe file won’t launch the program.  I’m using a Microsoft Surface computer, which as mentioned, has been working fine. 

Hey Mark, sorry for the trouble.  We’ll investigate this today and tomorrow, but in the meantime can you try:

  1. Login, and click “just watch”.

  2. Click the “back” arrow when you’re in spectator mode to go back to your bike, and bring up the pause menu.

  3. Try to pair from the pairing button in the pause menu

  4. See if you can ride that way.

The same thing is happening to me, Jon, on both a Windows 10 laptop and a Windows 8.1 desktop (with entirely different specs, same Internet connection). My husband’s Windows 8.1 desktop with the same video card as mine and the same Internet connection doesn’t seem to have a problem.

“Just watch” works, but the “Back/Menu” button brings up the same problem when I try to hit “Pair” or “Skip.” I reinstalled the launcher, rebooted the computer, and the problem still existed. I uninstalled Zwift on my desktop computer and am in the process of trying to re-install it, but it’s stuck on “updating” and won’t seem to go anywhere, even when I closed out of the Zwift process in the Task Manager and tried again. I’ll submit a ticket with the log file if I can’t get it to work soon.

I would say maybe it’s a Tacx FE-C trainer issue, as I’m pairing a Tacx Vortex Smart as a controllable trainer, but it happens on my laptop even with no ANT+ dongle and trying to hit “Skip” instead of “Pair.”

I have had the same issues.  On a Windows 8.1 machine with both a Garmin Vector S and a Cycleops Powerbeam pro.  Locks up with one or both.  Tried to “Just watch” and when tried to go back and pair locked up again.  Wondering if it a memory thing.  Thanks for looking into it.  

I have had the same issues.  On a Windows 8.1 machine with both a Garmin Vector S and a Cycleops Powerbeam pro.  Locks up with one or both.  Tried to “Just watch” and when tried to go back and pair locked up again.  Wondering if it a memory thing.  Thanks for looking into it.  

Does the problem go away if you rename the “prefs” file in your Documents/Zwift folder to “prefs2”? 

I actually deleted the prefs file on my desktop computer (after finally reinstalling) and it still didn’t work for me. But as I told Lindsay a bit ago, my husband then logged on to his account on the same computer (same Windows login, too) and it worked for him.

Didn’t work for me.   Still locked up after pairing even after starting in watch only and going the back way.


If you’d like my log files I can send them your way.

Mark, Jenn & Karissa - I spent a portion of my night digging into this and have found nothing suspicious.  We didn’t really even change much code here so it’s strange that anything is different at all.  Can either of you try renaming your Documents/Zwift folder to Documents/Zwift2?  Don’t delete it as there’s some stored/cached power performance data in there, but I’m curious if the problem happens with all that cached data missing.  

We will continue the investigation on Friday.  Sorry about that.

Karissa, I reset the password on your account (we can’t see users passwords) so I could try logging in to see if there was anything specific to your game save data, but even then I couldn’t reproduce the issue.  I’ll send you a password reset email so you can set it back to something you want.

As Jon suggested, I’d try moving the Documents/Zwift folder so that Zwift is essentially starting fresh.  I too had issues with the latest version hanging (once they added the new Mountain course/loop).  For me at least, it seems thing are working fine after a) moving the Zwift folder to Zwift.BAK and b) running in Full Screen mode (vs window’d).

Actually, I didn’t need to do anything to the folder. I just loaded up Zwift and it works now. :slight_smile: Maybe something you did shook something loose!

I changed the folder zwift to zwift2  and it everything paired up without issue.  Thanks for the suggestions and for looking into the issue.


I had a similar issue, I could start the game, but it wouldn’t pair, (when it had previously) and I couldn’t get the mouse appear and select anything, nor would the keyboard work in the game, but I could Alt+Tab out of the game, and the keyboard would work fine.

Renaming the Zwift folder and restarting it fixed all the issues.

Recent update on window 10 crash my zwift.exe. i removed the app and download the zift again but same problem zfift crash on loggin part.
Help pls


There is an outage at the moment:

Thx Allen was worrying that something bad happen with the pc