Zwift no longer detecting my Kickr


(Richard McTighe) #1

 Hi there,

I haven’t used my Kickr with Zwift for a few weeks. It was working fine before with both of my Windows 10 lap tops but now Zwift can’t find my Kickr. I’ve tried a new Ant + dongle, still same problem. I’ve tried deleting unpairing, repairing. I’ve tried deleting and updating Ant + drivers. I’ve tried connecting via Wahoo utility app and fitness trainer and both do work. I’ve tried removing the Ant + cable from the equation. I’ve re-set my computer with a fresh install of Windows 10. I’ve even read that installing Garmin Express makes sure you have the latest driver fixes for Windows 10 so I did that. Still no luck on both my computers. And Wahoo support doesn’t know what to suggest as the fact that I can connect to the Kickr via their app shows that the Kickr is working.

Please help! I want to get back to Zwifting…


(Nico Schekoff) #2

Mine was only detected after I updated to latest firmware 1.5.68.

At least as a FE-C compatible device. But this is a Kickr V1. Good luck!


(Paul Graham) #3

Maybe worth checking that the Garmin Express application isn’t sitting in the system tray waiting to grab the ANT+ dongle signal before Zwift has taken control Richard.

 


(Kevin Brown) #4

Try powering off your Kickr and powering it back in on.  That’s solved my problem of not pairing a couple of times in the year+ I’ve had it.


(Richard McTighe) #5

@Nico - thanks for that. Strange though because my Wahoo Utitlity app is showing 1.2.2 firmware, yet not suggesting a firmware update which I thought it did automatically. This would definitely be the problem if I’m not on the latest. I’ll pick this up with Wahoo. Thank you. @Paul @Kevin thank you both for your suggestions. I’ve tried and still stuck! I’ve switched to riding using just Wahoo Fitness on my mobile which feels like watching a black & white TV!