Zwift not responding / acting slow as if it is getting no resources from the computer to run

Just tried launching Zwift tonight and it’s just started behaving strangely. After logging in it behaves as if it is getting no resources to enable it to run from my computer. It cycles between not responding and using about 0.1% of my CPU according to Windows task manager. The music plays normally but the program itself is acting as if it’s only updating it’s state every 30 seconds or so. Is this Zwift? Or me. All other software on my machine appears to be behaving normally. I have plenty of RAM and CPU available. And Zwift was running normally yesterday. But I can’t find any other mention of people having this problem today. I also took a look in Windows Resource Monitor and it did seem as if it was woefully low in regards to network activity send and receive values (if I understood it correctly). It seemed to suggest that I was connecting he us-west-2 AWS and was sending and receiving <50B/sec at any one time which seems low but then I was on the pairing screen at the time. Could Zwift network issues even cause this behaviour? Am I just going off on a tangent?

Sounds like you have an internet connection problem (does not have to be at your end). Last time I used Zwift on a Laptop, it seemed to be entirely single threaded. Which is to say, any sort of network problem halted and subsequently crashed the UI.

If you’ve ever heard the (in early days AWS origin) advice “design for failure”, well, somebody didn’t even make it to “design”.

Tough luck.

1 Like

I have the exact same problem. Upon launch my Zwift is so slow and not responding frequently. I cannot even find any sensors. I believe this also manifests in a lighter way by losing all sensor connections when inactive on Zwift, even for a short period of time. There is a bug here. I am on an ASUS gaming PC with loads of resources and the latest software updates. My internet connection is fine and strong. All other apps are running just fine. Kevin

What graphics card do you use and do you have the latest drivers?

2 Likes

I think that I have all graphics needed … these seems more like a CPU connection issue … maybe it is graphics … I do not know … how do I even check what my Graphics Card is please? Thanks.

If you go to settings - About you should see your PC spec. also check Settings - Display - display adaptor properties.

Or you can download a program called CPU-Z that will give you all the information about your Pc.

1 Like

Thanks – Will try when home … does this really sound like a video card or video driver issue to you?

It can be and it is also easy to check.

The next option will be checking internet speed. Then programs running in the background.

When was the last time Zwift ran with no issues? maybe something got installed that clash.

Was broken last Wednesday… worked again on Thursday … did not use much until Today and was broken again … no new Apps … I have a monitor for Internet and it is working fine … all other Apps like video and such work fine too … I am pretty sure this is a Zwift connectivity issue as it is slow and then dead and the status bar says Zwift Connectivity issue every now and again before freeze … I am not alone with this problem … I wish everyone reported these kind of issues … I think that problems started with a Zwift update, but manifestation was less previously that I would just lose contact with sensor when inactive getting dressed while logged in for a race, etc …

while you are checking you could drop your .log files into Zwiftalizer.com. Do one from a ride that worked and one from a ride that did not, that can also help to find the problem.

Trust me when there are a big bug/issue social media just blow up with comments. :flushed:

I tried to use Zwiftalyzer today, but the files from the unstartable rides did not exist … is there somewhere to find them if I never get past the pairing screen? Should I “Just View” so that a file is created maybe? Thx

If you don’t get past the paring screen you won’t have a log file that is true.

what is the reason you don’t get past the paring screen? Is it because you cant get the sensors paired or does Zwift not respond?

Sometimes sensors do not pair – Sometimes Zwift just freezes and I have to force quit … Maybe I need to re-install Zwift?

It could be helpful if you post the complete specs of your PC (HD type, Memory, CPU, GPU and your internet speed)

Also a rundown of your sensors.

ASUS Gaming PC … it is pretty mega 5MB download Do not have more details here

Hmm, I’d try re-installing Zwift for sure. Do you have anything else running in the background (virus scan, auto back-up compression, etc…) that could be working with the HDD (or SSD)? That can often cause slow-downs.

Other possibility (though unlikely) is a lack of drive space.

1 Like

Ya, I agree with @EricC my recommendation is if you have a Win10 PC you should be running a SSD.

BTW, 5MB download is considered to be on the slow end these days.

It could also be that the RAM is maxed out.

There are a lot of things it could be, but until you post the specs it is just guesses for now.

Thx I will try to post the specs when I am home … what is an SSD? A Solid State Drive? This PC was “the thing” for gaming PCs not too long ago and it has always worked just fine, previously …

Yes, SSD = Solid State Drive and I would not run Win10 on anything else, especially a gaming PC.

Tonight I have:
Installed Zwift over itself. No difference.
Unistalled Zwift. Installed Zwift. No difference except this time on first launch from install it ran an update before it got to the select user dialogue.

I am not convinced it’s not Zwift. My machine has not knowingly changed between Sunday when it worked fine and Monday. (and today) when it doesn’t…

My brief computer specs (more can be provided if needed):
i7-3930k @ 3.2GHz.
16GB RAM
Windows 10 Pro 64-bit (10.0, Build 18362) (18362.19h1_release_svc_prod1.190628-1641)
2x NVIDIA GeForce GTX 980 Ti
Drive C:\ Free Space: 751.7 GB (SSD) (where Zwift is installed)
Speedtest.net as of this post: 219.98 Mbps download, 21.12 Mbps Upload

Looking at Zwift Log.txt files in My documents (only stating some lines that I think might help but I can provide full log if needed):

Game Version: 1.0.39812
Launcher Version : 1.0.50
Successful audio init!
Calling initialize_zwift_network()
Suceeded initializing graphics
Using ultra graphics profile
… (setting different res values. reporting syntax error. Unknown command “aniso 4”)
Changed resolution to 3840 x 2160
OpenGL 3.1.0 NVIDIA 417.01 initialized
ANT : ANT USB receiver found
…(Loading WADs, Loading Shaders etc.)
Got an access token
Attempting Token Login…
…(Many lines of Failed workout path…)
Logged in user: (##MY EMAIL ADDRESS###)
NETCLIENT:[INFO] Auxiliary Controller: TCP
NETCLIENT:[INFO] Auxiliary Controller attempting to connect to phone at: (###MY PHONE IP###)
NETCLIENT:[INFO] Auxiliary Controller started
NETWORK:error (6) sending player state
NETWORK:error (6) sending player state

PairingScreen CTOR
…(Bluetooth is found and is on)
NETCLIENT:[INFO] Auxiliary Controller failed to connect to socket: ‘No connection could be made because the target machine actively refused it.’ (10061)

…(Then in the logs the following lines are repeated,very similarly, over and over again)

[18:51:10] resize: 3824 x 2121
[18:51:10] Giant dt in app. dt = 9.02
[18:51:10] NETCLIENT:[INFO] Auxiliary Controller attempting to connect to phone at: (###MY PHONE IP###)
[18:51:10] NETWORK:error (6) sending player state
[18:51:13] ANT : Could not assign channel 0 to network 1
[18:51:14] NETCLIENT:[INFO] Auxiliary Controller failed to connect to socket: ‘No connection could be made because the target machine actively refused it.’ (10061)
[18:51:19] FPS 0, 5150, 22770, 8742
[18:51:19] FB resize: 3824 x 2121