Zwift not picking up trainer data


(Andrew Pease) #1

Hi  all

I am new to Zwift and yesteray I tried to get my setup working but had no joy. Im hoping someone with a more technical mind than mine can tell me what Im doing wrong.

Thanks in advance.

I have the Kinetic Road Machine II which is bluetooth capable. (link for reference: http://www.wiggle.co.uk/kinetic-road-machine-ii-smart-trainer/)

I have a garmin GSC10 Speed and cadence sensor and nothing seems to be working with Zwift. Zwift picks up and pairs with my trainer, but when I pedal it does not pick up any of the power out put, which means nothing happens on the zwift interface.

Im presuming that I am still missing a important sensor possibly, but at this point I am out of ideas.

 

 


(Gerrie Delport TeamZF) #2

Good morning,

are you on Windows or iOS?

 

Does you setup look something like this?

When you pedal on this screen do you see the speed and cadence change.


(Paul Allen (Watopia Wayfinder)) #3

I think you would need to use the Zwift Mobile Link to bridge the Bluetooth signal coming from the trainer to your PC.

Are you using a PC, Mac or iOS device to run Zwift?


(Andrew Pease) #4

I have started using an iPad

 

My setup when zwift picks up my sensors is as below
I have also tried pairing with the inRide app, but that is also not picking up data, I have submitted a ticket to Kinetic to see if they can also trouble shoot


(Gerrie Delport TeamZF) #5

Sorry Im not that familiar with the iOS setup and it is hard to see on that picture what is selected.

 

 


(Paul Allen (Watopia Wayfinder)) #6

Try pairing it as a power source instead of a controllable trainer.


(Rachel Kompass) #7

Make sure your firmware is updated on Kinetic app and then the kinetic app isn’t running after it’s updated.  Just a thought.  I ran into some troubles as well and that helped