Zwift not controlling Kickr Snap on Mac past 3 weeks


(Andreas Grønneng Hjelme) #1

Zwift works perfectly on my iPhone, but on my Mac the trainer is only a powermeter, and not controlled.
This has lasted about three weeks.
This includes:

  • No erg mode
  • No resistance changes on hills
  • Spindown fail every time

This is what I´ve done:
Paired as controllable (as always)
Reinstalled Zwift
Debugged bluetooth on Mac
Factory spindown in Wahoo app
Forget sensor in Wahoo app
Turned off Bluetooth on my iPhone

I repeat: Everything worked fine untill a couple of weeks ago, so my Mac and trainer has “what it takes” even with companion turned on.
Repeat 2: When paired with my iPhone, everything works. Spindown, resistance changes etc.

Please help, I zwift every day, and this is quite upsetting.


(Andreas Grønneng Hjelme) #2

I´ve now found the Companion-bridge to mac. Connecting via Companion, and not directly to Macbook gives me resistance on hills, and ERG-mode. Problem solved? Only partially.

The ERG-Mode has a delay I´m not used to. When I was connected directly trough my Macbook, ERG-mode would keep my watt constantly on 170/171w if my target watt was 170. When connected trough the bridge, I need to focus a litte bit to stay on 170, as increasing my cadense will increase my watt by 20-30 immediately. Anyone else have this experience?

Now Zwift community: Why won´t my Macbook control my trainer directly like it used to?


(Adrian Cartlidge) #3

yes I have experienced the same. When doing workouts the delay between power changes can be up to 40 seconds. When not doing workouts and just riding the controllable trainer is basically just a power meter. I connect directly to my Mac through ANT dongle.