Kickr ERG mode and spindown with Apple TV

I’ve got a Kickr and use it with my Apple TV (sensors via the companion app).

As of a few days ago, Zwift seems to have lost the ability to control the watts on my Kickr.

It started this weekend … I was doing a structured workout and Zwift lost connection with all my sensors. I figured something went wrong with the companion app, so I restarted.

After a while, I was able to get the sensor connections back up.

Unfortunately, Zwift didn’t appear to be able to control my Kickr. The workout was calling for a specific wattage but wouldn’t control the Kickr to make me put out that wattage.

I tried force closing the companion app & Zwift on the ATV. I tried restarting my iPhone & the ATV. I also tried uninstalling & reinstalling both the companion app and Zwift on my phone & the ATV.

I also tried doing a spindown calibration of the Kickr on the ATV, but it never detected a speed less than 2 mph, even with the kickr totally idle. Spindown in the Wahoo app worked fine.

The MacOS version of Zwift has no problem controlling the kickr.

One other thing … yesterday I upgraded my Kickr to the 2018 version (my wife gets my old Kickr) and saw the exact same behavior, so I’m pretty confident it’s not related to the Kickr.

Any suggestions?

Thanks!

I have the same problems :frowning:

I also have the same problem, and went through all the steps Red Rider went through.

Hopefully today’s update will address this issue, per the other kickr resistance thread:

Yep, that seems to have resolved the issue.

Hey @David_Greenyer @Lenny_Benny has the newest update fixed the problem for you?

Yes update is good. Thanks

Nope … it worked yesterday for a very short workout … but when I tried to do a workout today it started OK, but lost connection to the sensors about 10 minutes in. When I got the sensors reconnected, Zwift refused use ERG mode. It was calling for 85 watts but I was riding at about 120 watts.

Problem still exists.

Was there resolution or a fix for this issue? I’m experiencing the same thing. Thanks.

I’m having the same problem as well, sent in a support ticket yesterday.

I have same issue. Happens roughly every ride and than I have to fiddle for about 10 min to try to sort it out. Very annoying.

I thought this problem had been solved after last week’s update but it happened again last night, dropout then ERG not adjusting power.
Any solutions out there?

The latest update caused the same issue for me with my kickr and iPad setup. Worked fine before the update, but afetrwards i cant do a spindown and zwift is no longer changing resistance. Obviously an issue in the latest update as all was fine before. I have logged a support request.

2 Likes

After latest update on ATV I also cannot complete a spindown. It stops at 2mph every time when the wheels stops spinning.

+1

Yesterday the ERG wasn’t working at all. Lots of banter on the chat about the same issue. I have a cycleops hammer, though the other users complaining had a mix of neo, kickers too.

Same here, latest update broke my setup : Mac os x / qubo. No more ERG working.

Mine too ! Latest update on Apple TV renders the app unusable.

Calibration is way off.

And won’t complete a calibration.

Yet when the same setup is connected to an iPad without the update. It works and calibrates fine.

I’m just stuck on a tiny screen rather than my two dedicated 40" screens :man_facepalming:t3:

Sort of out Zwift !:rage:

Mine does this too. After the latest update on Apple TV renders the app unusable.

Calibration is way off.

And won’t complete a calibration.

Yet when the same setup is connected to an iPad without the update. It works and calibrates fine.

I’m just stuck on a tiny screen rather than my two dedicated 40" screens :man_facepalming:t3:

Sort of out Zwift !:rage:

I’m having similar issues. Are all of these trainers connecting via Bluetooth? Does switching to Ant+ resolve the issue? I have an Ant dongle coming later this week.