Zwift not connecting via Bluetooth to Suito-t or Garmin

I just purchased a new Elite Suito-t trainer and have been wanting to try Zwift. After downloading the app on my android phone (pixel 4a), I haven’t been able to connect to either the trainer or my Garmin for heart rate.

I’ve read a lot of similar issues but haven’t found a solution. After first having the problem, I downloaded the myETraining from Elite and connected both the trainer and the watch for HR with no issues, so I know the trainer’s BLE is working. To make sure there wasn’t interference, I deleted the myETraining app. I’ve restarted both my phone and the trainer on multiple occasions, and only opened the Zwift app with no other BLE connections to my phone (even the Garmin which I’ve turned off just to try to connect the trainer). Each time I’ve tried connecting, I’ve tried as a Power Source first, and then have Speed Sensor and Controllable. Have also just left the app search for 5+ minutes.

I’m at a loss. Hopefully there is a solution out there that I haven’t come across. Thanks.

Exactly the same issue for me but using an iPhone. I tried all this things as well but nothing to do?
Can somebody help?

Hi Nathan i have the same problema, on the app of elite everytthing Is ok , but when i try to use zwift, It can’t connect with elite suito, have you find a solution?
Thank you!

Exactly the same issue for me.
Frustrates me to the point I’m considering returning the Suito for a Wahoo instead.

Tried all of the above same steps (MyETraining, turning things on/off, searching endlessly, etc.).
Running Android 11 on Oneplus Nord 2.

Hopefully there’s a fix for it!