New Elite Suito - Connectivity problems

Hi there,

I just received my new Elite Suito yesterday. After the setting up the trainer and my Zwift account, I was able to successfully connect the trainer via bluetooth to my laptop. The laptop sensed the Suito right away and I connected to power, cadence and controllable trainer. However, when I began to pedal, I was getting 0 for watts/cadence/speed. I pedalled for 5+ minutes at different speed with no results, all while being paired with the Suito with no apparent connection issue. The exact same thing happened when I tried to pair the Suito to Zwift on my android phone. Finally, I tried out the MyEtraining app - same problem. Connected to the app via bluetooth but the app was not able to sense my pedaling whatsoever.

So in summary - brand new Elite Sutio - can connect to Zwift/MyEtraining app via bluetooth. But none of the apps are sensing my pedaling to any degree.

What I have tried so far: restarting trainer/phone/computer, disconnecting ALL possible other bluetooth connections, pedaling at a variety of speeds

Any ideas on what to do here? Thank you so much!

exact same problem here …no solutuin found so far

did you ever contact Elite support? i sent an email but received no response so far (only been about 12 hours though)

yes, same, but it really think it’s a connectivity problem …