Zwift No Longer Saving Ride on Exit

I’ve been running Zwift without issue for the past 6 or 7 months without issue. Over the weekend, Zwift started freezing up while saving my ride prior to exit. It would not post to my Strava and after the crash, showed my ride on the companion app as still in progress. I uninstalled/reinstalled the program and reconnected to Strava per tech support’s instructions. Today, I did a couple of test rides, only a couple of minutes long, to see if it would post. The program did not freeze up and crash but did not save the ride in my activity or on Strava.

I’m running the program off of a Microsoft SurfacePro Tablet running Windows 10:
Processor: Intel® Core™ m3-7Y30 CPU @1.00GHz 1.61 GHz
Installed RAM: 4 GB
128GB of Memory
System Type: 64bit operating system, x64-based processor

What was the distance of the test rides that were only a few minutes long?

1 Like

Less than a mile, just spinning the pedals for a minute to test the system

Bryan, Zwift by design does not save rides shorter than several kilometers. I do not remember the exact number, but a couple of minutes may be too short for a test. There was an article somewhere which explains this, but I do not have a link. This is by design, because a very short ride most likely was not a meaningful ride which people want to have in their Zwift or Strava or Training Peaks accounts. Do a longer ride, at least 5-7 minutes for your testing.

Thank you! I was not aware of that. I’ll give that a try.