Zwift Launcher fails to start Zwift app, with no error

Originally I had the 117 error but used the work around by copying an pasting the files from the downloads folder. This seems to have worked. However, the issue I am running into now is once I click ‘lets go’ to launch the app; it switches to the loading slides for a few seconds, closes and then nothing. The app doesn’t seen to even attempt to open and there is no error messages.

Further into troubleshooting I’ve noticed three of the files read as being 0kb in size, one of them being the application file. Its likely not all the essential files have fully downloaded before the 117 error and this is the issue. However, im not sure how to work around this. Really I think Zwift should download updates as one compressed file.

Any suggestions would be much appreciated.

-No other 117 work arounds have worked.
-I am missing the ZwiftApp, ZwiftHelper and ZwiftSetup files. If I could get these I think it should run

On trying to find another solution for the 117 error, the launcher log goes well until this point:

[9:05:33 2022-09-03] Patcher: “data\Worlds\world8\map.ztx” server file missing locally, but found in downloads – NOT adding to missing files list, rather present list.
[9:05:33 2022-09-03] Patcher: “data\Worlds\world9\map.ztx” server file missing locally – adding to missing files list.
[9:05:33 2022-09-03] Patcher: “data\Worlds\world9\visdb.dat” server file missing locally – adding to missing files list.
[9:05:33 2022-09-03] Patcher: Kicking download of missing local files from server…
[9:05:33 2022-09-03] Downloader: Failed to create file handle for “C:\Users\CNellins\Downloads\Zwift\ZwiftApp.exe”. Error code: 32.
[9:05:33 2022-09-03] Patcher: ERROR #Z117, FILE “Patcher.cpp”, LINE 602: Failed to download needed server files for update! (Last: “”)
[9:05:33 2022-09-03] Launcher: ZwiftApp.exe is not running.

My understanding is 32, means another instance is running however, there arent any instances showing up in taskmanager before the install and I only launch one instance when starting the update.

It won’t start without Zwiftapp.exe, that’s the game itself.

You need to uninstall and delete everything, reboot and start again. Or buy an Apple TV.

I understand I need the .exe, thats why Im trying to figure out how to get it, since the launcher fails to fully install everything.

As easy as buying an apple tv might be, I’ve just bought a new smart trainer and already have a powerful pc and large monitor so Ideally I’d like to avoid that.

I’ve redownloaded and installed the launcher countless times and I’m now using a fresh install of windows and the most up to date drivers.

I was being facetious about the Apple TV.

Whilst you could patch the files in, it’s not really what you should be doing. It shouldn’t be necessary, I’ve installed Zwift hundreds of times and genuinely not encountered that error once. Anyway I’m away at present so can’t help, but if you’re still stuck next week drop me a PM and I’ll see what I can do.

Ahh okay obvously got lost in text, the whole Apple TV thing just went over my head haha.

Thanks for the response. Hopefully its resloved by next week but if not your help would be much appreciated.

I did think about patching the files in but I just don’t know how to get them without going though the launcher, any ideas?

If not don’t worry about it and thanks again for the response.

I’d just stick them on my Google Drive. :wink:

1 Like

A common solution for the 117 error is to download it using mobile data rather than your wifi. This didn’t work for me.
However out of ideas I decided to tether my pc to my mobile but use my mobile connected to my home wifi and for whatever reason that worked. So anyone else with the same issue try that?

Zwift forums need a “comment of the day”

2 Likes

Your Dave filter has been calibrated!

2 Likes