Error 117 on updating software

I know there other old thread like this, but no one has the solution for my problem.
I tried to update Zwift on my Windows PC (who is running zwift from november 2019) and after a long stay on “Updating data\Video\CritCityVid1.bik” I always receive Error 117.
I removed Zwift, Dropbox, OneDrive, antivirus software. I erased Zwift folder under Documents and tried to lunch installer as administrator. No way!
I tried to reinstall my PC. No way!
I tried to install Zwift on another PC without Anti Virus, Dropbox and OneDrive. No way!!!

Anyone has Idea on what I can do?


Did you try everything that is suggested in this article?

Error Code: z117.

Hello Andrei. Yes, tried to install on another PC too, following those instructions, with no result!
Now I’m trying to install software on another PC with Windows 10 PRO and no Microsoft account configured. It seems impossible!!!

Try a different internet connection. Or VPN.

Thank you all… already tried 3 different connection :sleepy:

Fabio, I do not know how to troubleshoot your issue any further, but I have a thought… maybe it will help… from that little that I gathered from reading forums, Zwift consists of two parts, zwift launcher which is basically a script which runs in Internet Explorer, and zwift.exe which is the game itself. Zwift launcher is responsible for logging in and for checking for updates. For one thing, if you do not have Internet Explorer on your PC at all (the current version of IE is 11, and it is not the same as Edge), it might interfere with the loader/launcher. Also, there may be some Internet security features which you may have enabled in IE which could prevent scripts from running. Check on that. Maybe reset IE preferences to “factory default”. Also, about a year ago, there was an error caused by a certain script which launcher apparently downloaded from a storage server on Facebook. Many users reported it. That error did not crash Zwift nor did it prevent it from running, but this makes one think that firewall or VPN that blocks certain sites or connections could in theory interfere. I do believe that in you Documents folder you can also find log files of zwift launcher. Maybe they show something of interest, like some connections which did not happen.

Please note that you may have some sites restricted not only on your computer, but also on your home cable or DLS modem, wi-fi router, or VPN. Network provider is less likely, but who knows. As an idea, you could create a wi-fi hot spot on your cell phone, connect your PC to your phone, and see if update goes through with the hotspot. If it does, it means something is restricted on your network that is not restricted on your cell phone internet connection. Or take your computer to a friend, connect to their internet, and try updating from there. This could provide you with a valuable insight into “what it is and what it is not”.

You could also temporarily disable firewall on your computer or router to see if this helps. If it does, the next step will be to troubleshoot what firewall setting causes it. If your installer sits on downloading a benign video file for a while, maybe it simply times out every time because it cannot download one of the assets.

Today’s game release v1.19.2 fixes the Z117 launcher error for Windows and a related Z112 error for macOS. Please update your game app at your earliest convenience.

I have the same problem with Error 117. After a deeper search in the tech support bot, one thing came to my attention: Does the Zwift installer need the 1 .Edge Browser installed and 2 set as the default browser on my computer to be able to run the installation / update process correctly? ( can anyone from Zwift Tech or Forum experts “confirm” this necessity or am I having a wrong assumption here?)

if this was really the case, this is something that should be communicated clearly, before Installation process starts. I am not sure what percantage of people are 1. still running Edge and 2. set it as the default browser, I am sure not the majority of Windows users.

Directions in the support bot like: cleain the cache of the Microsoft Edge browser…would now make sense. Please let me know if I am on the road to success here?

Hi @X-Tri, welcome to the forums.

No, you don’t need Edge, I believe the launcher runs on Internet Explorer, so you do need that. It doesn’t need to be your default browser. Try clearing the cache on IE, not Edge and see if that works.

Hi Mike,
OK, I do not have IE installed, I will try if installing will that solve the problem, would not like to set it as default, thx