The zwift update the error code z112

Today morning is normal to using, but now when opening the software on pc, it’s updating and then notice error code z112 at line 602, what’s wrong with it and how can recover

Pc updating the zwfit, and then update error, code z112, at lime 602 at patch

https://support.zwift.com/en_us/error-code-z112-BknbSUdVH

Hi @NaiQian_Zhang welcome to Zwift forums.
Try these three steps please

  1. Search for “Zwift” in Windows Explorer.
  2. Delete all the folders and files that you find.
  3. Download the Zwift app and perform a fresh installation.

Doesn’t seem to work with this solution. I have tried numerous time to update it but no luck. Can you assist me?

@Jerry_O

Have you looked through the common causes in this support hub article?

A common issue is installing the Zwift app in a custom file path location, and not the default Documents folder path on your local hard drive will cause this.

Also common issue: antivirus / malware apps blocking Zwift. Check also your OS’s built in firewall settings. You might have to allow Zwift to pass through any firewall (software or hardware-based). See this other article if you need to open specific TCP / UDP ports on your firewall.

Thanks for the response. I have followed and tried the guidelines you mentioned, still no luck resolving this issue.

Can you please assist me?

Follow up on this please?

Hi,

I had this exact same issue and it was down to my internet connection. I was using a vodafone mobile router (just upgraded from landline) and i got the z112 error. I tried doing an install on my old ISP line and now it all works.