Update failed. Error Code: Z112 at Line 594 in Patcher.cpp

How can we resolve this? I can’t use my zwift… is there other way?

I have the same problem

i do!


Same issue brand new laptop, all drivers up to date. Ticket raised today. Hopefully it gets fixed quickly since this is a new laptop to get the full benefit from Zwift

me too!!!


So ticket answer says to delete the lot any trace including downloads folder. Re install etc etc. What I found was due to the large update needs a stable internet connection. I tried it again plugged in and it installed fine…happy days

Uninstalling, deleting all traces and then reinstalling didn’t work for me.

Did Zwift support come up with any other suggestions ?

Delete Microsoft Word, especially OneNote, then re-install with fresh downloads.  The auto-updating that these programs sometimes entail sometimes results in a fragmented installation. 

Ok, I think I’ve solved it.

The update process is failing to update the (jpg) image files. It’s downloading them but the file sizes and checksums don’t match.  All other file types appear to be updating properly.

Downloading the relevant image files manually, outside of Zwift, also produces mismatching files.

However, downloading the same file from the same url at work, results in an image file that does match at least the file size.

My suspicion is that my home (4G) broadband provider (vodafone uk) is recompressing image files and it is this which is making the checks fail.

The immediate solution I am going to try out is to (a) download the image files that need updating at work and then (b) copy them into the Zwift folder at home.

I’ll post back here with the results …

In the meantime, if this is the problem then the solutions would appear to include the following -


* Find a way to turn off 4G broadband provider 's image recompression.

* Accept that sometimes when I want to use Zwift I won’t be able to until either (a) after I next come to work or (b) I get a friend to download the files manually and email them to me. Neither is satisfactory.


* Reduce strictness of file checks for jpg files.

* Wrap each jpg file (e.g in a zip file) to defeat ISP recompression.

Zwift using “Cache-Control: no-transform”, at least for for images, could be the solution…

I can confirm that the issue does appear to be with Vodafone’s 4G network messing with the image files.  

If I download the relevant jpg files manually, including a “Cache-Control” header to disable caching, I get the correct size files. 

If I put these downloaded files in the Zwift download directory and set their timestamps to match those in the Zwift version manifest file then the Zwift updater process accepts them.

Zwift Support are being next to useless though.

One week on, all they’ve come back to me with is a standard response to turn router off/on, disable any VPNs, then delete and try to reinstall yet again.  They’ve completely ignored my comments about impact of cache options.

Time to cancel my subscription methinks.


Same problem , Anyone can explain step by step to solve it.Thanks

Same problem , Anyone can explain step by step to solve it ???


Because i was behind a proxy (pfsense), i had the same error. For some reason files are blocked during the download, created a hotspot on my phone and dowloaded the content. Zwift is installed and my internet bundle is gone for this month

I had the same issue and investigated.

It seems that some ISPs use transparent proxies that cause older versions of the update files to be downloaded thus failing the updater on CRC checks.

Zwift should change their updater to use the HTTPS protocol instead of HTTP. This way the files wont be cached.

Until they do so I made a python script that downloads the updates from their cdn over https.

You must have python installed and some modules. I dont offer support on the script but hopefully you will figure it out. 


Lets hope Zwift will fix the updater soon.

Good luck

Good work Kostya, my pfsense proxy is also transparent, i will test/use your script the next time zwift needs an update.

Same problem, I am not that computer literate so have no clue what you guys are talking about in the comments above.  Is there an easy step by step solution?  Zwift what is your answer?  I1m also using the vodaphone internet in South Africa


try to stop your dropbox.


Zwift has support? Could have fooled me.