Zwift launcher causes script error on Windows 10

Hi,
I am getting a script error (https://connect.facebook.net/en_US/fbevents.js) on Win 10 when I start the launcher and every time I change language (before logging-in). I verified it on a virtual machine with a new Win 10 installation - same behaviour.

Is this a bug (either at Zwift or FB)? Does anyone know, if the popup can be disabled somewhere in Windows?

Thanks! Frank

I have got the same problem on laptop (Windows 10 ver.1909) with zwift installed last week (installed earlier on another laptop works without any errors). But when window with script error opens, I don’t choose yes or no, I just close this window and Zwift app loads successfully. It’s a temporary solution, but works good :slight_smile:
I tried many posted solutions (clearing Internet Explorer cache, etc), but nothing solves this error now.

Hi all,
I found a way to avoid the script error. It was important for me that “it just works” as I would like to use the Zwift-Login script from zwifthacks.com. Background is that we are using Zwift with more than one rider and need to logon and logoff frequently.

The script error described above does not appear when Windows 10 runs in US-English as main language. I had it in German orgiginally.

Cheers,
Frank

I have just the same problem. Any solution to this problem? I just uninstalled and reinstalled Zwift, but this didn’t have any effect …

Here’s the full error message:

"Script error
An error occured in the cript of this page.
Rule: 0
Sign: 0
Error: Script error.
Code: 0
URL: https://connect.facebook.net/en_US/fbevents.js

Do you want to proceed executing the scripts on this page?"

Hi @Lander_De_Frene! As described above the script error disappears for me as soon as I change the system language to US English. Several people have also in another group reported that they issued support tickets with Zwift but they seem to ignore/neglect it. Maybe they are all using it in US English setting and therefore claim that there is no such bug. It is sad but this seems to be no priority to fix for Zwift.

Frank

P.S. BTW: no votes here either - so people seem to accept it.

This has just started happening on my computer in the last few days, since I updated to Windows 10 build 1909. It’s bloody annoying. A reinstall has not changed anything.

Hi @Tim_Collins_PACK, please note that for me, ONLY the change of the language worked. I mentioned it earlier here as well. Not sure, what your standard language of Windows is? Mine was German and the bug disappears as soon as I change the language of Windows to English.

Also… very few/no one is voting here. Also the Zwift support staff seems to ignore it. Everyone that has the bug should vote I think. Otherwise we will not get attention from Zwift.

Frank

Hi Frank,
I am in Austria, Win 10 German.
Had this issue sometimes on Christmas, but just 2 or 3 times. Now everything OK - that’s why I do not vote.
Are you sure you have all Win & Zwift updates?
Ride on!

I also get this message on my Windows 10 pc. Most of the times I run on android. But sometimes I want to login and start on my pc. So I can see my achievements, edit my avater and so on. But after I click on yes, the game starts without an issue.

Yes, we can click on it and it disappears. But we are for “Zwifters” in the Family and need to continuously logoff and logon. It becomes a bit annoying overtime. I am also frustrated that Zwift does not even accept it as a bug. The support staff also recommends to reinstall etc. They say this, knowing that is appears also on a fresh and clean Windows installation.

@Milan_Rost Do you remember anything specific you did before it disappeared? Thanks. Frank

No, just all Win 10 Updates.
And FYI - had no problems zwifting with the issue, everything as usual.

Sorry, did not save the error message. Will take a look at the logfiles, if there is anything.

Same with my Win10/Zwift installation, running German system language. No issues zwifting at all, just having that rather annoying script error.

Error also on Dutch windows versions. Both win7 (:flushed: EOL I know, upgrade in progress) and win10

Script error is also seen on Windows 10 (Finnish).

same here in Dutch Win10

Great. ‘Popularity’ of this bug seems to be growing after a couple of months since it has been reported. Now it is just Zwift that has to acknowledge it. One of their (hopefully existing) testers needs to change system language to something else than English. Thank you all for the votes. Frank

you have to download the newest v18 zwift-login.ahk file from zwifthacks.com - this is not a Zwift issue it’s a zwifthacks issue - already tested here in switzerland - works now like a charm :wink:
https://zwifthacks.com/zwift-login-version-18/

1 Like

Hi @Stefan_Kumli_Xterra,
Could you please explain how you came to the conclusion that the latest Zwift Login version from Zwifthacks solves the problem compared to the version before? I am not sure if your conclusion is correct:

  • the described script error appears also in Zwift versions that do not use any modificaiton or add-on like the login script from Zwifthacks
  • the described script error appears also on a completely new and clean Windows installation with only Zwift as additional installed program (and the mandatory dependencies of course)
  • to my knowledge (was in a discussion with Jesper between v17 and v18) v18 of Jespers script only added functionalitiy to press the “Let’s go” button also in the other offered Zwift languages. E.g. it was not able to press “Los geht’s” if Zwift was set to German.

Again… it is unclear for me how you came to the conclusion that it is not a Zwift problem.

Thanks.
Frank

1 Like

Hi Frank

Well, first, I had the same script error and the newest zwift-login.ahk file solved the problem on two laptops here in the house. Second, this error is explained at the zwifthacks homepage with v18.

If you login with a microsoft account, not a local one, to your computer and install zwift, the files in your personal documents folder may be synchronized from your microsoft OneDrive. The personal documents folder is the place the zwift-login.ahk and other scripts are placed.

But of course, maybe there are multiple similar errors?

BR Stefan

1 Like