Script Error Help!

Hi,

Hoping someone can help with this issue?

Zwift was fine yesterday, opened and ran without issue. Today I’ve had this script error appear when Zwift starts and then when the program runs its impossible to use due to graphics either missing or running slowly and ‘jerky’, not smooth.

Tried reinstalling but nothing is working, can anyone help?

TIA

Line 0
Char:0
Error: Script Error
Code: 0
URL: htt ps://s.pinimg.com/ct/lib/main.d71a97dd.js

I have the same issue, it won’t pair properly now with the kickr. Drops watts

We’re brand new and experiencing the same issue. Would love to actually use our new bike

I have also the same problem with my Kickr Core. No signal found. I tried the connection with Bluetooth n ANT+, it still doesn’t connect to zwift

Same here. 1st session, 1st bug.

I got the same script error when trying to switch user and login. The error points to a Pinterest javascript which causes IE11 to return an error. But I don’t think it has any impact on the game itself, or the ability to switch user and login.

Same here. I’ve been running zwift for a couple of years with everything stable. The errorhas been ocurring for the past few days (after last update?). Doesnt appeear to affect the game though.

Same problem here. Can’t log in. Can’t use Zwift.

By the way, the javascript file generating the error is a Pinterest js file. I have never opened Pinterest on this computer. No idea why a pinterest script is running from the Zwift loader. Suspicious.

Same script here. I can ride anywhere between 5 minutes to an hour, but eventually it will kick me off. We need another update immediately.

Hi all,
I had this a while also in a similar way with a Facebook script-error.
Since then, I do the following with these script errors:

In the linked post I explain how to do it. Basically, you let IE11 within Windows 10 block the script.

I am repeating the steps here:

  • open “Internet Options” on your Windows 10 machine (the Options are in Internet Explorer, not Edge)
  • open Tab Security
  • select Zone “Restricted Sites”
  • Press Button “Sites”
  • Add the URL that caused the error, i.e. https://s.pinimg.com/
  • close and press o.k. (not sure if it requires a restart but maybe)

Enjoy :slight_smile:,

Frank

7 Likes

This worked!! Thanks Frank

Thanks for the workaround Frank. WHat the ■■■■ is the zwift loader doing with pinterest and facebook scripts?

1 Like

Do anyone else have a solution for this problem? I can’t change the settings in IE because I use Zwift on a managed PC and the system administrator doesnt allow me to do these kind of changes.

I dont understand why Zwift doesnt solve this problem or post any public info since it look like it affects a lot of customers (or have they but I’ve missed it?).

There is the problem, you will need admin rights while installing. May ask them to install Zwift and should solve your issue.

1 Like

Misunderstanding.

I have admin rights for installation programs so I have no problems to install Zwift.

The prioblem I have is that I get this strange scriptError when I start Zwift on my computer. Frank_Krauthauser wrote a solution for that scriptError, but I cannot use that solution. The reason is that I have a managed PC and I dont have the rights to add new restricted sites in InternetExplorer.

Does anyone else have a solution how to get rid of the scriptError that (I believe) get Zwift to hang?

That script error in the launcher cannot cause the game itself to hang. The launcher is a separate program (zwiftlauncher.exe) to the game (zwift.exe). Just choose to continue to run scripts to log in.

Hi all, yes I confirm that the script error will not cause to hang Zwift, but it is really disappointing to see that zwift requires almost every 2 weeks an update by having the risk that such an error can occure. Script errors occure not the first time. I have automated the startprocess and this error causes to break any automation. However Zwift requires to get paid every month and here I would expect that this issue gets solved esp. when mutiple people have the same issue.
Is here any zwift responsible who could answer about the current status?
Thanks Andreas

2 Likes

Same issue here. 100% clean install of Win10 Build 19042.572 on Nov 4th 2020 on a basement dedicated indoor cycling PC. No browser installed except the ones installed by MS (Edge+IE). I installed the drivers, a password manager, Zwift and PerfPro, but that’s it.

1 Like

Same issue here.
As I don’t have a smartphone, I connect directly with my PC, ignoring the message, and log on. There doesn’t seem to be too many issues. Just wondering if this makes a difference?