Script Error On Start Up


(Mathias Fell) #1

I am getting this script error on startup:

Zwift

I have updated my OS (Windows 7) and cleared the cache on IE. Last week Zwift has worked correctly.

What can I do?


(Oj (B)) #2

HI,

I have this issues since last year!!!
The only way to start the game was to click the X , not yes or no buttons. (several times cause the error script window keeps appearing)

Sadly, after this morning’s update, after clicking many times on X, the login page stays blank.
Tried reinstalling the game, same issue.

Any ideas Zwift guys?

Thanks


(Oj (B)) #3

Anyway, it seems that our OS is missing some libraries…or something


(Julien Dehaudt) #4

Same issue on my Windows 7 (64bit).
This is my first installation and no way to get it working.

How to workaround this problem?


(Julien Dehaudt) #5

Just for sharing for those who are experiencing this trouble, updating Internet Explorer to version 11 (I was stuck on version 8) solved the issue.

For that I also had to install prerequisites Windows update.

Hope this helps !


(Felix Hb) #6

I had the same problem with Windows 10 Pro (64-bits).

I also tried everything I could, re-install Zwift, rollback Windows updates, clear IE cache, disable script debugging, still stuck at a white screen behind the script error.

Then I switched to an other Windows user account on the same PC, and Zwift launched no problems!
Also worked when creating a new user.

I don’t know what’s blocking it on my other account but it’s a temporary fix.

Hope this helps.


(David Connolly) #7

Same issue, similar system (Windows 7 Pro 64 bit).

Zwiftlauncher has been throwing out various script errors pretty much since I signed up a year ago, but you could always click past the script errors and it would launch fine.

Yesterday, the launcher automatically updated (as is normal) but this time there seemed to be extra script errors and finally the splash page for logging in appeared as totally blank.

I took down all the latest Windows updates, re-installed Zwift and the problem remains the same. The errors are coming from JS script files with the following names…

https://secure.zwift.com/auth/resources/7.2.3.ga/login/zwift/dist/js/rh-sso-theme-lib-0.4.1-201811092030.js
https://secure.zwift.com/auth/resources/7.2.3.ga/login/zwift/dist/js/rh-sso-theme-common-0.4.1-201811092030.js
https://cdn.segment.com/analytics.js/v1/O1rtCHaDnAJken0dFyBSf1txk7dgi04i/analytics.min.js
https://cdn.segment.com/analytics.js/v1/O1rtCHaDnAJken0dFyBSf1txk7dgi04i/analytics.min.js
https://cdn.amplitude.com/libs/amplitude-4.4.0-min.gz.js
https://connect.facebook.net/en_US/fbevents.js

Going by the date stamps built into the JS filenames (201811092030), this looks like it was caused specifically by the update.

My current launcher version shows as 1.0.44, game version is 1.0.31664

Going from above replies, changing to newer browser or new user seems to help so this sounds like there’s something hanging about that the browser install/user change is cleaning up. I’ve cleared caches, etc but no joy ?!


(Oj (B)) #8

So it seems a broader issue caused by the latest update, so Zwift should step up with somw advice/fix. I’ve already raised a ticket. Zwift guys??

Unfortunately, I can confirm that in my case, a new user scenario has no efect on running Zwift, same pack of JS errors
(windows 7 64b)


(Cora Baltes) #9

Having the same troubles, with this error, a lot of script files:

https://secure.zwift.com/auth/resources/7.2.3.ga/login/zwift/dist/js/rh-sso-theme-lib-0.4.1-201811092030.js
https://secure.zwift.com/auth/resources/7.2.3.ga/login/zwift/dist/js/rh-sso-theme-common-0.4.1-201811092030.js
https://cdn.segment.com/analytics.js/v1/O1rtCHaDnAJken0dFyBSf1txk7dgi04i/analytics.min.js
https://cdn.amplitude.com/libs/amplitude-4.4.0-min.gz.js
https://connect.facebook.net/en_US/fbevents.js
https://cdn.segment.com/analytics.js/v1/O1rtCHaDnAJken0dFyBSf1txk7dgi04i/analytics.min.js

Please try to fix this issue asap!

Thank you


(Tom Kiernan) #10

For me, the Script Error window stopped happening after updating to Windows 10 Version 1809 yesterday.


(David Connolly) #11

Good to know but minimum requirements are Windows 7 64bit (see link below) so for those of us who can’t (don’t want to) move to Windows 10, we still need a solution from Zwift Support.

https://support.zwift.com/en_us/what-are-the-minimum-device-requirements-for-zwift--S1C6I6OB7


(Manuel Ebner) #12

Hi,

Same Problem, since last update a lot of Skript errors (more than usually). Blank login screen.
I’m running win 7 64bit

:no_bicycles:


(David Connolly) #13

Found the issue (least on my setup - Win 7 64 bit).

As per @jLn above, I updated my IE8 to IE11 and it seems to have resolved the script errors. I naively assumed that when Windows installed all the system updates that it also updated IE but it seems it did not and I still had IE8 (albeit the latest version of it).


(Oj (B)) #14

Guys,

Indeed, upgrade to IE 11 is the solution, did it and working 100%.
Zwift answer my ticket with the same advice.
" Since our launcher uses your platforms default browser (Internet Explorer(IE) in your case) to launch Zwift, the first thing you will want to do is make sure that it is the most current version (currently IE 11). There are step by step instructions for checking what version of IE that you have right here​. Once you have made sure that you are on IE 11 please clear your cache and cookies and try to run Zwift again."

Hope it helps