JS Script error on launcher startup


(Anthony Biancardi) #1

I’ve suddenly started receiving the following script error on startup of the launcher. I’ve restarted my PC, reinstalled Zwift, and cleared my internet caches, all with no success…I ran Zwift yesterday with no problems, and there has been no change to my pc (that I’m aware of).

OS: Win 10 Pro
Edge: 42.17134.1.0

Line: 2
Char: 10999
Error: Unable to get property ‘getitem’ of undefined or null reference
Code: 0
URL: https://secure.zwift.com/auth/resources/7.2.3.ga/login/zwift/dist/js/rh-sso-theme-lib-0.4.1-201811092030.js

I am unable to get past this error and launch Zwift.

Edit: Update and fix provided in a lower post. Internet Explorer settings need to be reset. Follow the link here: https://mywindowshub.com/how-to-reset-internet-explorer-in-windows-10/


Zwift launcher stopped working since update (app is not launched - white blank window)
(Warry Pieket) #2

Hello Anthony,

I have the same issues. Yesterday everthing was fine but today I get script failure messages. Tried the same things you did and send a email to the Zwift support (no reply yet…)

Did you find a solution?

Update:
I found a solution in earlier posts… Creating another account in Windows and start Zwift from there works for me. Still looking for a proper solution because this is a lame work-around


(Anthony Biancardi) #3

I ended up having to launch Zwift on my other laptop to get my ride in this morning. This is undesirable for me, however.

Finding a proper solution to this would be great.


(David White) #4

I’m also having a script error, line 2 char 10999 unable to get property ‘getitem’ of undefined or null reference 0

then a long URL. This something server side?


(Warry Pieket) #5

Don’t think it is… otherwise more people would have replied.
Still no word from Zwift…
Check the forum entries earlier on this subject!


(David White) #6

Well after trying all sorts from messing with IE 11, forcing windows to upgrade to version 1809, reinstalling zwift, the only way it’ll work is by creating a new user on the same pc, and running it from that account. Weird…


(Ivo Franic) #7

Same issue here, Windows 10, Zwift worked fine until two days ago, now I can’t launch it.

I tried everything mentioned in this thread plus the one linked in the first post, only thing that worked was logging into Windows with a different user.

Hope someone at Zwift is looking into this so it can be fixed properly.


(Володимир Андрущенко) #8

Windows 7/64.
I update Internet Explouer from 8 to 11 and solved this problem.
Regards!


(Warry Pieket) #9

That doesn’t work…
I’m on Windows10 and Google Chrome… Besides Zwift worked before and now it don’t…
Still no reply from Zwift Support!


(Paul Allen (Watopia Wayfinder)) #10

Zwift uses Internet Explorer/Microsoft Edge for the login screen, not your default browser.

What are the specs of your PC?


(Володимир Андрущенко) #11

What lenguage in your Windows? Try English.


(Warry Pieket) #12

Hi Paul,

My point is that I had a working set-up in Windows10 and Chrome. From one day to the next I could not login anymore. Meanwhile I made another account (on the same laptop) and everything works fine…

I think (being on the same laptop) the software zwift calls upon is the same. So it still puzzles me why on my original account it stopped working and everything is smooth when I login in as another user…

I already tried Edge but without succes

Thanx anyway!


(Warry Pieket) #13

I will give it a try (most of the software is Dutch, some English - like Zwift)


(Ivo Franic) #14

My Internet Explorer is already the latest version, so is Edge. Windows is set to English as it has been since day one.

Something with the security settings and/or Java Script must have changed with a recent Windows 10 update, as all of us with this issue got it at the same time. Something about our default Windows profile no longer lets us access the Zwift servers, but a new profile works. Very odd, and annoying.


(Anthony Biancardi) #15

I sent an email to support a few days back, including all my log files and I’ve not had any response back since then.

Because the workaround you describe requires a different user, it sounds like something in the specific user settings at the OS level is getting mucked up and preventing Zwift from executing it’s login scripts correctly.

What that could be, or how to potentially fix that is beyond me though.


(Ivo Franic) #16

I have good news, I finally have a fix for this issue :slight_smile:

Out of desperation I contacted Zwift support using the web interface, and within the hour I got a response from John S. that fixed the problem.

All I had to do was reset my Internet Explorer settings. You can follow instructions from this link

I didn’t delete my personal settings BTW, and I didn’t even restart Windows, just launched Zwift and no more JS error :slight_smile:


(Warry Pieket) #17

I have followed the steps and Zwift starts up again!
Thanks, great work!


(Anthony Biancardi) #18

This worked perfectly! Thank you!


(David White) #19

Cheers, also worked for me


(Pieter Macquoy) #20

Sounds like javascript caching issues… after the miserable move from the earlier support platform which rendered all google search results invalid, you would think Zwift needs to hire some competent web developers…