Zwift keeps losing signal

hi i have a smart trainer and every so often the signal between the trainer and zwift get lose for a few seconds with is really annoying.

how do i find out if it is zwift issue or if it is the trainer?

thanks

Are you connecting via ANT+ or Bluetooth?
I’ve found that Bluetooth has a long range, whilst with ANT+ the dongle needs to be within 50cm of my trainer to get a good signal.

Regards

David

hi i have a Ant+ Dongle in my pc, and that is about a meter away, but when i start the zwift software and it finds the trainer on the setting cog it is set for the beta, use inbuilt bluetooth of trainer

so i am assuming it is using the ANT+ as i dont have Bluetooth on my PC, might get an extension lead for the dongle and see if that works

It typically works much better with a USB extension cable. You can also run your log file through Zwiftalizer which should help you determine if it is indeed ANT+ dropouts. You can also compare before and after USB extension cable.

1 Like

ah great, thanks will have a look at that

Also, make sure that you are connecting to the ANT+ FE-C connection. Using that you should not need the usb extention cable.

1 Like

i am assuming it is, because i dont have Bluetooth on my PC, but will check

thanks

Hey Stephen!

I’m sorry to hear that you’re having issues pairing your trainer to Zwift, I’m here to give some knowledge and tips on the connections and how to improve such. (You may also check out this Knowledge Base page, to see the common causes for interference amongst ANT+)

I’d first like to start out by saying, not having one of the ways to pair (ANT+ or Bluetooth Low Energy/ BLE) won’t really negatively impact the other receiver/connection. Secondly, since you’re using ANT+ to pair your trainer, you’ll need an ANT+ dongle and most likely an extension cable (preferably not longer than actually required to reach your trainer, as a longer cord usually causes for more dropouts or connectivity issues as a whole, trough ANT+.) You want an extension cord to limit the amount of distance between your signal’s broadcast (your sensors/trainer are what is being broadcasted) to your receiver (ANT+ dongle and computer/device, whilst the dongle is connected.)

You’ll also want to make sure to turn off (and completely close out) all other fitness applications as they could be “hijacking” your ANT+ dongle. (Meaning they are using it and Zwift can’t, if any are open/running.) There is also a chance that you’re receiving signal interference, which could be from a wide range of electronics, from your modem to even your microwave. Anything that broadcasts, or gives of a 2.4ghz frequency can cause for interference between both, ANT+ and BLE connections. Please limit the amount of electronics that broadcast at this range, to ensure the best connection possible. Another common cause/factor for interference between the sensor and receiver, that is overlooked most times, is a simple fan. Fans generate electromagnetic fields (It’s how the blades move), which happen to kill most electronics running through such, including any signal, so please make sure there isn’t a fan blocking the connections. (If your fan is in between your sensors and dongle, move it please and see if the issue gets better.)

For issues such as pairing, I’d recommend reaching out to our support team and seeking out help from our technical support team. The reason being that, there is a large amount of things that could be causing this issue and we’d help limit down the amount of possible triggers/causes, by running through some more troubleshooting steps and requesting addition files from your PC, if needed.

You can reach out to tech support, via this link.

I hope to hear/see that you’re able to pair correctly soon!

Ride On!

hi. the Zwiftalizer was helpful, it showed the dropouts of the ANT+ and it suggested changing the WIFI channel, so i have done that and will try that tonight, then next i am going to try putting it in and extension lead if that does work, guess it is just a process of elimination

thanks