Zwift is recognizing the wrong GPU


(Jon Edwards) #1

I just got a HP 690-024 with a Ryzen 5 2400g processor. This processor includes an integrated gpu (the AMD Vega listed on the zwiftalyzer screenshot). Zwift seems to be setting my graphics according to this, instead of the Radeon 4gb GPU. I have the HDMI cable plugged into GPU’s output. Task manager confirms that the game is using the radeon gpu. What else can I do? The shadows look terrible as I have a square of pixelated shadows that follow my rider around.


(_) #2

Sounds like a funky BIOS primary display device setting. You could take a look at your BIOS setting for display devices and verify the on board 15DD display adapter is disabled, and the RX580 is enabled and set to primary. For HP’s i think its F10 repeatedly after power on to get into the BIOS.


(Lin) #3

You should not need to go in the BIOS for this. You should be able to make the necessary changes while in Windows forcing Zwift to always use the Radeon.

If you right-click on the desktop, there should be a Radeon settings option. Once in there, you want to find a setting that allows you to “Add Application” or the like. Then you will want to add the path to the Zwift.exe file (Zwift itself… wherever it is installed). Lastly, if I remember correctly, there should an option to set the graphics for Zwift. Choose/set high performance or whatever it might now be called.

I apologize for the above description. I don’t regularly use Windows and it’s been a while since I have had to do the above. But if you poke around, you should be able to get yourself sorted w/the above information.


(Jon Edwards) #4

Thanks guys for the responses. This is as much as I got into this morning as I still wanted to get a ride in before work. The only option that I see that allows me to override zwift is on the anti aliasing. It appears in the settings for both gpus. I will explore later, but I presume that zwift is “seeing” the first gpu and making a decision to run at basic profile.


(_) #5

The pic above confirms my suspicion that you need to disable the onboard (CPU) graphics adapter in the BIOS. Though you may be able to find a way with the Radeon software to bypass the onboards graphics, that’s not how it should be done if you are never going to use it.

HP and many other system builders are known for not shipping products with correct BIOS settings.

If you have a dedicated GPU in a Windows PC as well as an integrated CPU graphics chip best practice is to ‘disable’ the onboard graphics adapter in the BIOS. Once you disable the onboard graphics in the BIOS, Windows programs, Radeon software, and most importantly Zwift, would not even know the 15DD exists in your system.


(Jon Edwards) #6

@_Pedals, I have read about this in other forums about freeing up dedicated ram associated with the integrated gpu. Some seems to have been successful, while others not so much. In the short term, I think I am going to try this as task managers shows that zwift is actually using the correct gpu, just assigning me a lower graphis profile: Graphics Performance - ThinkPad P52


(_) #7

Good luck with whatever you try. But seriously this is a PC building 101 issue.

If you have a dedicated GPU in your system, you disable onboard graphics in your BIOS. Period.

There isn’t any situation where this practice doesn’t apply when it comes to PC’s and how they should be setup. Give HP a call or check out their support page for your machine if going into the BIOS is something you are not comfortable with.


(Gerrie Delport TeamODZ) #8

You paid all that extra money for a nice GPU and you are thinking of using the integrated one? :face_with_raised_eyebrow:


(Jon Edwards) #9

No, I am using the more powerful one, but zwift is using the integrated one to define my graphics profile. Why doesn’t zwift trust me to choose my graphics settings appropriately? :roll_eyes:


(Gerrie Delport TeamODZ) #10

I think this is because your system decide what is best and for some reason your system want to use the integrated one.

When ever i build a PC I disable the integrated Graphics it solves a lot of issues.

just search disable integrated graphics.

P.s the Bios is not as scary as it used to be 20 years ago. :slight_smile:


(Gerrie Delport TeamODZ) #11

I did a benchmark search on Zwiftalizer.com and it look like that even with the rx 550 you will still be on the basic profile.

EDIT: I should have searched for the RX 580 and that is a different story, you will get a LOT better than basic, I would think Ultra will be achievable.


(Jon Edwards) #12

I have been reading in other forums and I think I am going to try it based on yours and @_Pedals responses. Other people with this system have at least been able to force the integrated card to dedicate less ram using bios, even if the systems kept re-enabling the integrated card. If nothing else, I will benefit from the extra ram.


(_) #13

He has the RX 580, depending on whether it is the 4GB or 8GB version (probably the 4GB) I’d say 1080 Medium/High/Ultra depending on road traffic to maintain an Average higher than 60 FPS.


(Gerrie Delport TeamODZ) #14

Sorry the picture was so small I saw 550, I will update my comment.

In my experience anything above 30FPS on very busy roads is fine. (my Heart Rate is so high I don’t notice the difference)


(Jon Edwards) #15

My TV is only a 720p, so my goal with this desktop purchase was 720 on high (or medium on NYC days.) The zwiftalizer screenshot with 1080 was just me trying settings to see what would happen.


(Jon Edwards) #16

@_Pedals @Gerrie_Delport The HP’s bios options are disappointingly primitive compared to name brand motherboards. The only options I found that appeared to be related to gpu’s only had two choices, primary or non-boot. Since I am certain it is the correct graphics card that is actually powering the game, I left it alone.

I did get some partial resolution by copying the high.txt settings to the basic.txt file. At 720p, I had good fps while still only using about 2/3’s of the gpu’s capacity. Hopefully that leaves me some headspace for busier days.

Thanks for your patient responses, and if you have other input I am all ears.


(Lin) #17

Again, it’s not a BIOS issue. You should be able to find the correct setting to adjust from within Windows which will force Zwift or any other application to use the Radeon instead of the integrated graphics chip. Double check that you have the latest drivers and/or Radeon app. Poke around in the Radeon settings. Contact HP or AMD? Google… I’m sure someone else has this same computer and/or problem.


(Jon Edwards) #18

I plan on opening a support ticket with zwift. Copying the the graphics profile from high into the basic has hacked me to a satisfactory situation in the mean time.


(_) #19

Wow, HP is not doing you any favors. Assuming your goal is to get Zwift to use the RX 580 as your primary card, which it still doesn’t look like it’s doing.
You could try switching the profile of those 2 ATI VGA Controllers in the BIOS. Maybe also try upgrading the BIOS if there is a better one out there. But, with that Motherboard your best option may be just to disable/remove the 15DD display adapter from your device manger in Windows.


(Gerrie Delport TeamODZ) #20

I would sugest trying the following.

Windows 10: Click Start (Bottom left windows logo), Type "Control Panel), select Control panel,

Got to Device manager:
image

Right click on your integrated Graphics
:image

Select Disable device:
image

Reboot and see if it work.

You can always go back and Enable the device using the same steps.