How to get Zwift running on the Discrete Graphics Card off the Laptop?

Hi,

I’ve got a Dell G5 15 SE with

  1. Integrated AMD Radeon RX Vega 7
  2. Discrete AMD Radeon RX 5600M

I’m using the current AMD Display Driver https ://drivers.amd.com/drivers/dell-ryzen-mobile-4000-series-radeonrx5600m-adrenalin-2020-july15.exe

Also the discrete graphics card is selected in the Windows “Display settings” -> “Graphics settings” for the ZwiftApp

But Zwift is always running on the integrated graphics card (1) with the Basic Profile.
What am I doing wrong and how do I get Zwift to run on the discrete graphics card (2)?
Thanks a lot!

Can you disable the iGPU in BIOS?

Thanks @DaveH. But sadly there is no such option. The BIOS is very basic.
None the less this would be a tedious workaround since I would have to reboot before and after playing Zwift.

Quite some time ago the AMD driver had an option to toggle the graphics card but It seems to be no longer there or I can’t locate it.

Not if you just used the discrete GPU all the time, which is presumably the issue. Laptop uses the iGPU when you’re not gaming to save power but Zwift isn’t respecting your settings and just uses whatever the ‘main’ or default display driver refers to.

Try this:


Seems like that might be based on settings within older drivers as you mentioned, that are now removed in 2020 versions. Found a long thread of people complaining about it on AMD’s website. Your choices are to roll back to a 2019 version or try messing with the Windows power options as per this post.

https://community.amd.com/thread/246289#comment-2965544

PS: link to the last 2019 version before the change is at right at the bottom if you want to go that route.

is your laptop plugged in when you’re zwifting? if you’re running on battery, it might choose the lower power card.

Thanks a lot @DaveH.
Yes, Zwift (C:\Program Files (x86)\Zwift\ZwiftApp.exe) is completely ignoring the Windows Setting since other Applications are correctly using the Graphics Card assigned to them. I only have this Problem with Zwift and the power cord is plugged in.

I don’t know if I can use the 2019 driver since the Laptop has Smartshift and a dedicated AMD driver for it. Maybe I’ll try it out. To my understanding the following article says the newer Radeon driver has the ability (again) to select the graphics card: https ://hothardware.com/reviews/amd-radeon-vega-7-performance-in-dell-g5-15-se
I posted a question on their page and hope it gets answered

I upgraded to the new driver win10-radeon-software-adrenalin-2020-edition-20.8.2-aug17 but see no improvement.

Messing with the power options also fails from your link (https ://community.amd.com/thread/246289#comment-2965544) because the necessary Entries are missing. Strangely I have only 4 (Desktop background settings, Sleep, Display & Battery).
Sorry I’m not allowed to post images yet.

Hey
I have the Same issue. Did you finde a solution? It’s really annoying that zwift looks worse on my gamging laptop then on an old t430

Hi,
I got it running on the preinstalled Windows by using “AMD Radeon™ Settings Lite” https ://www.microsoft.com/de-de/store/p/app/9n9370crz0fn) I found on https ://www.deskmodder.de/blog/2018/12/17/amd-radeon-settings-lite-als-app-im-microsoft-store/
In the App I selected System -> Switchable Graphics, added C:\Program Files (x86)\Zwift\ZwiftApp.exe and assigned it the AMD Radeon RX 5600 and finally was able to play Zwift in High settings. Although I’m wondering why I get neither Ultra nor 4k.

But frustratingly not on my own Windows Installation where I want it, the Installation leads to a Error 0x803FB005 after downloading the App.

Today I cant even open the Windows Store Link because I always get
“An error occurred while processing your request.
Reference #30.57a71002.1598785951.134e4d04”
Edit: At least the Windows Store Link is working again.

yeah I have the same error message. Does not seem to bee fixabel witht eh current AMD software. I guess eiterh they or zwift must update…