Zwift hanging on save/exit [June 2023]

Thanks Paul. My average is in the mid-80s, but occasional spikes to much higher.

I have plenty - PC is used for little else other than zwift with a 512GB SSD - it is definitely hanging on the upload stage.

Between us we seem to have ruled out almost any combination of things that I can think of.

1 Like

Ditto, dedicated PC that’s not messed with.

1 Like

Hi folks, just a quick update on this one: We’re working on a fix and are planning on rolling it out in the next game release.

In the meantime, many have reported that if the Save screen is stuck spinning, they can navigate up to the little “Back” arrow, select that, and then try ending the ride again which often succeeds.

Thanks for your patience as we worked through this one.

Great news Evan, can you put us out of our misery and give us a clue as to what’s causing it.

Aside from who shot JFK this is the worlds largest mystery.

Haha - This issue was caused by an intermittent issue in our UI code resulting from an previous change, so it wasn’t related to network performance (although I appreciate you and others helping dig into that line of reasoning - it did seem correlated).

Is this still an active case? I am getting it happening all the time at the moment. Is it still being worked on? I am on1.48.0 (120544) and running on windows. In the UK.

try turning off video screenshots if you have it turned on and see if that helps.

seems to have worked for others recently.

1 Like

Thanks Chris! I have done this and it certainly looks better. Talking with Zwift support about this at the moment, so hopefully we will get a proper fix!

when video screenshots were first introduced it was an issue then it seemed to resolve itself so maybe something has reverted back somewhere in the background that they need to fix again.

Seems like a few people are having this issue again.

I have the latest update as of 11/25/23 and this worked for me. Thanks!

Using a MacBook Pro and just downloaded the latest Zwift. 1st ride in a long time and I’m getting this issue.

Hey, is there a suggestion that this is fixed? Still a problem for me on Win10, 60 GB free space. Even with no snaps or no save to club, still freezes after save. No way to go up to the back button once it freezes. I just have to wait for the Windows End Task dialog box to pop up. Ugh!

Have you turned off video screenshots?

Where is that setting in Windows ap? Ive gone in to watch only for testing, no snaps taken… but haven’t found where to turn it off.

Menu then Settings and then under preferences, scroll down.

Just installed zwift with latest updates on a win 11 laptop and I have the ‘saving’ no response issue.

Tried to disable the video screenshots but the app becomes unresposive when the OK button is pressed!!!

Other settings I can change without issue.

Hey guys, not sure it’s the same.

I save the workout, it creates a FIT file but doesn’t upload the activity to Zwift. Doesn’t upload to Strava or Garmin.

I manually uploaded and its fine, but not in Zwift.

Yep, I just ran into the same issue that you were describing, except on Windows 10.

Freezing and unresponsive when saving activity, so I had to force exit with Alt+F4. Came here to see a suggestion of turning off video screenshots, but when I went to confirm the setting, again freezing/unresponsive requiring Alt+F4 to terminate the program. So frustrating.