Zwift hanging on save/exit [June 2023]

just to ruin most theories - i never press alt+F4 and i get this.
I sometimes use the menu and save buttion and still get it
I sometimes use the companion app to save and i get this.
Sometimes when i use the menu and save route i don’t get it, sometimes when i use the companion app i don’t get it.

I don’t think this is to do with what we’re doing. I’m sure this is dependent on the speed from where you are to zwift’s servers at the time you try and save.

I’m now thinking along the same thing. It’s looking like a geographical issue. That’s certainly 3 UK based and 2 Europeans if I’ve got that right.

if only someone had thought to mention that weeks ago :wink:

I’m in Canada but I wouldn’t be any further away than the entire east coast of the US.

Top of the class if you’ve cracked it

Toronto, Ontario. I don’t know where their servers are, but assuming California at worst, I’m probably as close, net geographically speaking, as NYC. I doubt it’s geographical.

They’re in the AWS Oregon site. There is a ping test on

Think that theory might also have collapsed:
Bay Area, West coast, USA… I’ve been getting the (indefinite?) Save hang on all my Zwift rides regardless of time of day (and regardless of whether I grab save from the desktop or companion app, whether I change the name, select images, or whether I let Zwift spam the club I’m not really a member of).

How much HD space do you have left?

SSD or Olde mechanical HD.

Thanks Paul. My average is in the mid-80s, but occasional spikes to much higher.

I have plenty - PC is used for little else other than zwift with a 512GB SSD - it is definitely hanging on the upload stage.

Between us we seem to have ruled out almost any combination of things that I can think of.

1 Like

Ditto, dedicated PC that’s not messed with.

1 Like

Hi folks, just a quick update on this one: We’re working on a fix and are planning on rolling it out in the next game release.

In the meantime, many have reported that if the Save screen is stuck spinning, they can navigate up to the little “Back” arrow, select that, and then try ending the ride again which often succeeds.

Thanks for your patience as we worked through this one.

Great news Evan, can you put us out of our misery and give us a clue as to what’s causing it.

Aside from who shot JFK this is the worlds largest mystery.

Haha - This issue was caused by an intermittent issue in our UI code resulting from an previous change, so it wasn’t related to network performance (although I appreciate you and others helping dig into that line of reasoning - it did seem correlated).

Is this still an active case? I am getting it happening all the time at the moment. Is it still being worked on? I am on1.48.0 (120544) and running on windows. In the UK.

try turning off video screenshots if you have it turned on and see if that helps.

seems to have worked for others recently.

1 Like

Thanks Chris! I have done this and it certainly looks better. Talking with Zwift support about this at the moment, so hopefully we will get a proper fix!

when video screenshots were first introduced it was an issue then it seemed to resolve itself so maybe something has reverted back somewhere in the background that they need to fix again.

Seems like a few people are having this issue again.

I have the latest update as of 11/25/23 and this worked for me. Thanks!