Zwift exits abruptly after displaying "logging on" [October 2021] [SOLVED]

Hi, this is really incredible for me, Zwift has been truly reliable on my current setup, a laptop running Windows 7. It ran fine last Wednesday when I got on, but this evening I’ve been having nothing but problems - I even missed a meetup with my IRL cycling friends. What has been occurring is that Zwift is starting normally, the blue screen comes up, the music starts, then when I get to the info window that says “Logging in…”, all of a sudden Zwift exits completely. I’ve examined the log files to no avail - the last entry I see in every log file (and I’ve tried to get in at least a dozen times so far) is:
[timestamp] NETCLIENT:[INFO] Auxiliary Controller failed to connect to socket: ‘No connection could be made because the target machine actively refused it.’ (10061)

Any idea what is going on? Planning to Zwift regularly on weeknights now that the outdoor weeknight club rides are over for the year!

That message is the game looking for the Companion app, so shouldn’t be relevant to your issue.

Edit: or the game looking for Direct Connect devices over your network. :thinking:

That’s what I figured - I even shut down the Companion app on my smartphone to see if that helped, but again no dice. Thanks for the information on that though!

Try with your ANT+/Bluetooth dongle unplugged and see if it’s actually crashing just prior to the pairing screen. Also try deleting knowndevices.xml and prefs.xml - the game will recreate them don’t worry. You’ll just need to re-pair your devices and set up the resolution etc again. But could sort it.

Alternatively try a complete reinstall of the game. Nuclear option is starting afresh with Windows 10, which would be a very good idea tbh.

I’ve just had this same problem. Zwifted yesterday with no issues. Eventually used my phone to zwift. I also use windows 7 and my drivers are all up to date.

There is no reason to be using Win7, upgrade to Win10. Win7 has not been supported by Microsoft for years now.

Windows 10 not supported on my zwifting laptop.

Experiencing same issue. Screen disappears after successful log in.

Same here. I am on Windows 10. Zwift disappears just when the device connect screen should appear.

Same Issue. Windows PC. Worked last night. Tonight it crashes right after it says successful logon.

Same here, windows 8 laptop, frustrating evening yesterday, tried re-install and made no difference, had no problems like this for ages, might bite the bullet and try updating to windows 10 but that will probably go wrong as well so hoping someone smarter than me (easy) can find a solution! Cheers everyone, I`m counting on you!

This sounds like more than an isolated issue then.

This is lame. WIN 8 here and can’t log in, keeps kicking me back to the desktop

Just started seeing the same problem today. I have a Windows 10 laptop that is only used for Zwift (patched up to date for Windows and Zwift).

It worked a couple of days ago, the last time I used Zwift.

Today it crashes

  • I can login into Zwift Launcher
  • I press ‘Lets Go’
  • The main Zwift application loads
  • It gets to the logged in screen
  • But it crashes just before I would expect to see the ANT sensor screen

I have tried the following - all with no effect

  • Swapping from WIFI to Ethernet
  • Unplugging the USB ANT+ dongle
  • Reinstalling Zwift
  • Formatting the Laptop, reinstalling Windows and Zwift

From the log file I see it always fails at the same point, the last log file entry is

Experiment service disabled assert abort
Loading WAD file ‘assets/Noesis/noesis.wad’ with file

Any suggestions?

Win8 does not log in. ZWIFT opens and when it comes time for the game to start, program quits and sends. Me back to the desktop. After a few tries and a few restarts. I’m not riding and trying to fix.any help out there?

Why are you still on Windows 8? You should upgrade to Win 10.

Thanks for the help

Same here , Setup using Windows 10 with Zwift has been working for ages but as of today - i get to the login screen - get to hear that nice piece of music :slight_smile: - and then … gone - it disappears.

I uninstalled and re-installed Zwift completely
Updated it completely (takes about 10 minutes)

But issue remains

I don’t believe that.

1 Like

It has to be something going on with the server (Zwift) side - I just tried again this morning and same thing - but this time Zwift doesn’t even get past the blue intro screen!

One thing I noticed is that when I start Zwift using the launcher on the Windows tray, it is not requesting to log in - it is already showing me as such (my name and thumbnail image appearing in the upper right of the login box). I’m thinking this might be something to do with an incomplete shutdown of my last successful Zwift session, which was 8 days ago.